Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003869 [JEDI VCL] 02 Installation block always 2006-08-23 10:25 2007-01-03 13:03
Reporter IGC View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003869: Fatal error: Unable to open file 'JCL.LIB'
Description Hello.
I had created a project in my laptop using Borland C++ 6. For the project I installed JCL/JVCL 3.00
Everything worked perfect. However, I am trying to port everything to my desktop computer. I installed borland, JCL/JVCL 3.00 with no problems. Everything seems to be fine.
When I open the copied project, I get a couple of warnings about Bitmaps that cannot be found, but I just ignore them and I proceed to compile / make.
No problems compiling the source code. However, when I try to link it, I get an error saying: Fatal error: Unable to open file 'JCL.LIB'
I've checked my Laptop and I do not have that file, so I don't know if I really need it, or if this is caused by any other missing files.

Thank you.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010012)
obones (administrator)
2006-08-24 02:48

If you do not have Jcl.lib then you have not installed the JCL correctly.
(0010019)
IGC (reporter)
2006-08-24 08:33

I followed the installation instructions and both processes (JCL and JVCL) completed without any errors or warnings...

I will try to install it again and see if that solves it. But I tried it a couple of times with the same result.

Do I need to check any special option so JCL.LIB is created, or is a core file that should always be created when installing.

Thanks
(0010145)
obones (administrator)
2006-09-19 08:15

It should always be created.
(0010504)
obones (administrator)
2007-01-03 13:02

Use the latest version from below, it installs just fine :

http://jvcl.sf.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2006-08-23 10:25 IGC New Issue
2006-08-24 02:48 obones Note Added: 0010012
2006-08-24 02:48 obones Status new => feedback
2006-08-24 08:33 IGC Note Added: 0010019
2006-09-19 08:15 obones Note Added: 0010145
2007-01-03 13:02 obones Status feedback => resolved
2007-01-03 13:02 obones Fixed in Version => Daily / SVN
2007-01-03 13:02 obones Resolution open => fixed
2007-01-03 13:02 obones Assigned To => obones
2007-01-03 13:02 obones Note Added: 0010504


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker