Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003900 [JEDI VCL] 00 JVCL Components block always 2006-09-13 09:29 2007-01-04 04:02
Reporter drader View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003900: Application with both Standard and CustomDoking features raise an unneeded assert condition
Description The assert condition in the
function TJvDockClient.CreateTabDockClass(TabHost: TForm): TJvDockTabPageControl;

doesn't allow me to uses CustomDocking feature.

I can't understand any real reason for this kind of assert
Additional Information function TJvDockClient.CreateTabDockClass(TabHost: TForm): TJvDockTabPageControl;
begin
  Result := nil;
  { copy properties of the JvTabDockPageControl's DockClient
    from the form it contains. }
  TJvDockTabHostForm(TabHost).DockClient.Assign(Self);

  Assert(TJvDockTabHostForm(TabHost).DockClient.CustomDock, 'DEBUG HELPER: Not working!');

  if (FTabDockClass <> nil) and (FTabDockClass <> TJvDockTabClass(ClassType)) then
  begin
    Result := FTabDockClass.Create(TabHost);
    Result.Align := alClient;
    TJvDockTabHostForm(TabHost).DockableControl := Result;
    TJvDockTabHostForm(TabHost).PageControl := Result;
    SetDockSite(Result, True);
  end;
end;

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010239)
obones (administrator)
2006-09-29 06:45

Well, it says it "Not working". Try to remove it and see what is not working, propose a bug fix and we'll remove this assert.
(0010263)
drader (reporter)
2006-09-30 06:02

I already removed the assert and I hadn't any problem.
This assert totally prevents the use of CustomDock feature.
Couldn't it be a refuse?
(0010300)
obones (administrator)
2006-10-06 02:38

hum... I'm a bit uneasy at removing the assert without extended testing. Can you do this with the examples from the JVCL?
(0010325)
drader (reporter)
2006-10-06 12:31

Ok!
Try this simple test:

Take a docking demo, for example DockOptionDemo.
Open DockWindows.pas and set lbDockClient1.CustomDock = false because we don't want to dock this form in a hypothetical customdock panel.
Enable the asserts, compile and try to tabdock the forms .... you will get in this assert condition ... this doesn't make sense.

If you remove the assertion it works fine.
(0010521)
obones (administrator)
2007-01-04 04:01

This is now fixed in SVN.

- Issue History
Date Modified Username Field Change
2006-09-13 09:29 drader New Issue
2006-09-29 06:45 obones Note Added: 0010239
2006-09-29 06:45 obones Status new => feedback
2006-09-30 06:02 drader Note Added: 0010263
2006-10-06 02:38 obones Note Added: 0010300
2006-10-06 12:31 drader Note Added: 0010325
2007-01-04 04:01 obones Status feedback => resolved
2007-01-04 04:01 obones Fixed in Version => Daily / SVN
2007-01-04 04:01 obones Resolution open => fixed
2007-01-04 04:01 obones Assigned To => obones
2007-01-04 04:01 obones Note Added: 0010521


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker