Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003913 [JEDI VCL] 00 JVCL Components major always 2006-09-19 01:40 2007-01-22 08:39
Reporter ZENsan View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003913: TjvScheduledEvents don't saves all information about events
Description TjvScheduledEvents don't saves all information about events. It saves only this information for any type of schedule (using INI or Reg storage:

Eventname=Event
Stamp.Date=732573
Stamp.Time=64800000
TriggerCount=1
DayCount=1
Snooze.Date=0
Snooze.Time=-1
SnoozeInterval.wYear=0
SnoozeInterval.wMonth=0
SnoozeInterval.wDay=0
SnoozeInterval.wHour=0
SnoozeInterval.wMinute=0
SnoozeInterval.wSecond=0
SnoozeInterval.wMilliseconds=0
Additional Information Damo can be used from my 0003912 previous report
Tags No tags attached.
Attached Files zip file icon JvScheduledEvents.zip [^] (10,510 bytes) 2006-09-20 03:02
? file icon JvScheduledEvents.patch [^] (23,920 bytes) 2006-10-11 00:57
? file icon JvScheduledEvents1.patch [^] (22,455 bytes) 2006-10-12 06:52
? file icon JvScheduledEvents2.patch [^] (22,935 bytes) 2006-10-12 10:11
? file icon JvScheduledEvents3.patch [^] (21,410 bytes) 2006-10-12 10:14

- Relationships

-  Notes
(0010140)
obones (administrator)
2006-09-19 02:58

Can't you investigate why it's doing this and propose a workaround/fix ?
(0010143)
ZENsan (reporter)
2006-09-19 07:22

Ok, I will try.
(0010147)
ZENsan (reporter)
2006-09-20 03:01
edited on: 2006-09-20 03:03

Here is updated version of unit.
I tested with all combinations of schedules.
Save/Restore works fine.

One minus (from previous version also) is that when retoring events, they are added as new (also when event names is the same) if LoadEventStates(false).

And one my programming minus(maybe more) is that I don't know (have no time to learn) how to save weekdays as "set" with WriteSet method. Here I used bit setting in integer value.

(0010180)
obones (administrator)
2006-09-26 01:22

Look for JclIntToSet, JclStringToSet
(0010181)
ZENsan (reporter)
2006-09-26 05:57

Thanks for hint, I will update my source and then upload new version.
(0010182)
ZENsan (reporter)
2006-09-26 06:18

I have already tried this, but some my mistake with that PTypeInfo...
begin
....
  AppStorage.WriteSet(AppStorage.ConcatPaths([Path, ItemName + IntToStr(Index), 'WeekDaysOfWeek']), TypeInfo(TScheduleWeekDays), AWeekDaysOfWeek);
... no error, but also nothing happens. What I am doing wrong?
(0010231)
obones (administrator)
2006-09-29 06:29

A few comments:

I don't like having dozens of arguments AT ALL. Please find another way.
For the TypeInfo, ensure that the value returned by the call to TypeInfo is not nil. If it is, then there is something weird. And you can always trace what it is doing.
(0010341)
ZENsan (reporter)
2006-10-11 00:58

This works fine. Sorry, but I used Integer to save days of week in weekly shedule - maybe someone will have more time to investigate and change that to WriteSet.
(0010342)
obones (administrator)
2006-10-11 01:07

Well, yes, it works fine, of course. But this is not acceptable code as it is not clean by any mean. As it is, I won't accept the proposed patch.
(0010346)
ZENsan (reporter)
2006-10-12 06:21

Ok I will investigate and then upload path with WriteSet.. Now it saves (in my version) but not restores..
(0010348)
obones (administrator)
2006-10-12 06:57

Let me insist:
Saving sets as integer, well, I could live with it.
But having so many arguments to the save and restore function, this is simply NOT acceptable. Pass an object containing the values, even the schedule directly.
(0010350)
ZENsan (reporter)
2006-10-12 09:50

Understand, ok. I thought that you are talking about integer as set. Ok I will correct source.
(0010351)
ZENsan (reporter)
2006-10-12 10:15

In third patch I think all is ok - I have also removed unusable comments and unused variables.
(0010464)
ZENsan (reporter)
2006-12-11 07:02

Maybe it is possibel to apply patch at end?
(0010574)
ZENsan (reporter)
2007-01-22 06:29

Hey! Comon! Working fine, integrate! :)
Also uses WriteSet/ReadSet as you wished.
(0010576)
obones (administrator)
2007-01-22 08:38

This is now in SVN but your patch had to be fixed because it included removal of some earlier fixes. This takes time and pushes the issue down the list of priorities.

- Issue History
Date Modified Username Field Change
2006-09-19 01:40 ZENsan New Issue
2006-09-19 02:58 obones Note Added: 0010140
2006-09-19 02:58 obones Status new => feedback
2006-09-19 07:22 ZENsan Note Added: 0010143
2006-09-20 03:01 ZENsan Note Added: 0010147
2006-09-20 03:02 ZENsan File Added: JvScheduledEvents.zip
2006-09-20 03:03 ZENsan Note Edited: 0010147
2006-09-26 00:54 ZENsan Issue Monitored: obones
2006-09-26 00:54 ZENsan Note Added: 0010179
2006-09-26 01:22 obones Note Added: 0010180
2006-09-26 05:57 ZENsan Note Added: 0010181
2006-09-26 05:57 ZENsan Note Deleted: 0010179
2006-09-26 06:18 ZENsan Note Added: 0010182
2006-09-29 06:29 obones Note Added: 0010231
2006-10-11 00:57 ZENsan File Added: JvScheduledEvents.patch
2006-10-11 00:58 ZENsan Note Added: 0010341
2006-10-11 01:07 obones Note Added: 0010342
2006-10-12 06:21 ZENsan Note Added: 0010346
2006-10-12 06:52 ZENsan File Added: JvScheduledEvents1.patch
2006-10-12 06:57 obones Note Added: 0010348
2006-10-12 09:50 ZENsan Note Added: 0010350
2006-10-12 10:11 ZENsan File Added: JvScheduledEvents2.patch
2006-10-12 10:14 ZENsan File Added: JvScheduledEvents3.patch
2006-10-12 10:15 ZENsan Note Added: 0010351
2006-12-11 07:02 ZENsan Note Added: 0010464
2007-01-22 06:29 ZENsan Note Added: 0010574
2007-01-22 08:38 obones Status feedback => resolved
2007-01-22 08:38 obones Fixed in Version => Daily / SVN
2007-01-22 08:38 obones Resolution open => fixed
2007-01-22 08:38 obones Assigned To => obones
2007-01-22 08:38 obones Note Added: 0010576


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker