Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003956 [JEDI VCL] 00 JVCL Components minor always 2006-10-14 05:50 2006-10-16 13:21
Reporter Kiriakos View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003956: JvTabbar repeat scrolling does not work with the left button
Description In JvTabbar repeat scrolling does not work with the left button (works OK with the right button)
Additional Information Resolution

In methods
- TJvCustomTabBar.ScrollButtonsMouseDown
- TJvCustomTabBar.ScrollButtonsMouseMove
- TJvCustomTabBar.ScrollButtonsMouseUp

change the logic to the following:

  Result := False;
  if (FBtnLeftScroll.State <> sbsHidden) then
    Result := HandleButton(sbScrollLeft, FBtnLeftScroll.State, X, Y, FBtnLeftScroll.Rect);
  if not Result and (FBtnRightScroll.State <> sbsHidden) then
    Result := HandleButton(sbScrollRight, FBtnRightScroll.State, X, Y, FBtnRightScroll.Rect);


Note: "not Result" added to the second if statement.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010361)
obones (administrator)
2006-10-16 01:04

Any example to show this ?
(0010365)
Kiriakos (reporter)
2006-10-16 04:35

The issue is easy to replicate.
- Create a new Win32 application.
- In the main form add a tabbar with say 10 tabs
- Compile and fire.

Andy has recently added repeat scrolling to the JvTabbar. This means that if you keep the scrolling buttons (at the right side of the tabbar) pressed the tabs scroll continously. This currently works with the right scrolling button and not the left button. I reckon Andy will understand the problem and the fix immediately.
(0010368)
AHUser (developer)
2006-10-16 13:21

Thanks. This is now fixed in SVN.

- Issue History
Date Modified Username Field Change
2006-10-14 05:50 Kiriakos New Issue
2006-10-16 01:04 obones Note Added: 0010361
2006-10-16 01:04 obones Status new => feedback
2006-10-16 04:35 Kiriakos Note Added: 0010365
2006-10-16 13:21 AHUser Status feedback => resolved
2006-10-16 13:21 AHUser Fixed in Version => Daily / SVN
2006-10-16 13:21 AHUser Resolution open => fixed
2006-10-16 13:21 AHUser Assigned To => AHUser
2006-10-16 13:21 AHUser Note Added: 0010368


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker