Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003961 [JEDI VCL] 00 JVCL Components major always 2006-10-17 07:08 2006-10-19 14:40
Reporter aml1005 View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version 3.20
Summary 0003961: JvRichEdit.PlainText loses extended characters
Description Set text in non-standard charset by RTF stream, then set PlainText:=true. The text is converted to ?. Works fine with TRichEdit.
Additional Information In attached - run and press Start and then "set plain text". (I'm using XP)

[of course in an ideal world the "text" property would just respect the
Font.Charset...but TRichEdit doesn't do that either since about Win95]
Tags No tags attached.
Attached Files zip file icon RichBug.zip [^] (276,713 bytes) 2006-10-17 07:08

- Relationships

-  Notes
(0010375)
remkobonte (developer)
2006-10-18 17:24

This should now be corrected in Rev. 10985 of JvRichEdit.pas

Please check it and give feedback whether it works or does not work for you.

Note that in your example application you set the PlainText property of the standard VCL TRichEdit component AFTER you stream in data. This should be done BEFORE you stream in data. If you do so you will notice that TRichEdit does not work the way you want.
(0010378)
aml1005 (reporter)
2006-10-19 13:56

Seems to work well now, thank you.

Note sure about your note.. I didn't do that because, as you say, it doesn't work. But thanks to this update I can now do better things.
(0010379)
remkobonte (developer)
2006-10-19 14:40

Okay, thanks for the feedback.

- Issue History
Date Modified Username Field Change
2006-10-17 07:08 aml1005 New Issue
2006-10-17 07:08 aml1005 File Added: RichBug.zip
2006-10-18 15:38 remkobonte Status new => assigned
2006-10-18 15:38 remkobonte Assigned To => remkobonte
2006-10-18 17:24 remkobonte Note Added: 0010375
2006-10-18 17:24 remkobonte Status assigned => feedback
2006-10-19 13:56 aml1005 Note Added: 0010378
2006-10-19 14:40 remkobonte Status feedback => resolved
2006-10-19 14:40 remkobonte Fixed in Version => Daily / SVN
2006-10-19 14:40 remkobonte Resolution open => fixed
2006-10-19 14:40 remkobonte Note Added: 0010379


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker