Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003969 [JEDI VCL] 00 JVCL Components crash always 2006-10-26 02:24 2007-06-19 04:59
Reporter jascha View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003969: JvInspector.Clear causes AV
Description If I add a Component with JvInspector.AddComponent(panel1,'test')
then play around a bit with the Inspector and call JvInspector.Clear from within a MouseDown event I get a AV very often (sometimes I have to do it serveral times, depending on which propertys I have changed in the Inspector)

I have added a little application where you can always reproduce it.
1. Click on somewhere on the Formbackground -> The panel gets selected in the Inspector
2. Click on Font in the Inspector
3. Click on the Panel to Clear the Inspector -> you get an Access Violation

You have to do this in one go without using Alt-Tab or something like that between the steps
Additional Information
Tags No tags attached.
Attached Files rar file icon jvinspector.rar [^] (5,262 bytes) 2006-10-26 02:24

- Relationships

-  Notes
(0010387)
jascha (reporter)
2006-10-26 02:27

If I add the Component only with JvInspector.AddComponent(panel1) everything works fine
(0010535)
outchy (administrator)
2007-01-04 09:24

I cannot reproduce with the latest source, do you have any other step?
(0013418)
obones (administrator)
2007-06-19 04:59

No news, considering this fixed.

- Issue History
Date Modified Username Field Change
2006-10-26 02:24 jascha New Issue
2006-10-26 02:24 jascha File Added: jvinspector.rar
2006-10-26 02:27 jascha Note Added: 0010387
2007-01-04 09:24 outchy Note Added: 0010535
2007-01-04 09:24 outchy Status new => feedback
2007-06-19 04:59 obones Status feedback => resolved
2007-06-19 04:59 obones Fixed in Version => Daily / SVN
2007-06-19 04:59 obones Resolution open => fixed
2007-06-19 04:59 obones Assigned To => obones
2007-06-19 04:59 obones Note Added: 0013418


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker