Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003973 [JEDI VCL] 00 JVCL Components minor always 2006-10-29 14:12 2007-06-19 02:50
Reporter Arioch View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0003973: JvMemoryDataset, troubles with .RecNo
Description 1) SetRecNo method should call *Scroll events.
Look at TBDEDataSet.SetRecNo or TClientDataSet.SetRecNo

Thus it is better to like like that:
~~~~~
procedure TJvMemoryData.SetRecNo(Value: Integer);
begin
  if (Value > 0) and (Value <= FRecords.Count) then
  begin
    DoBeforeScroll; // Arioch
    FRecordPos := Value - 1;
    Resync([]);
    DoAfterScroll; // Arioch
  end;
end;
~~~~~


2. Seems like UpdateCursorPos is not to be called from GetRecNo, ro some of routines it calls is implemented wrong, i didn't got ends together yet.

So it is to be done yet.
Additional Information
Tags No tags attached.
Attached Files ? file icon Project1.exe [^] (234,496 bytes) 2006-10-29 16:27
zip file icon MemoryDataset, GetRecNo in OnCalc.zip [^] (1,902 bytes) 2006-10-29 16:28

- Relationships
related to 0003461closed Bug en MemoryData when in CalcFields events field = Dataset.RecNo 

-  Notes
(0010393)
moore (reporter)
2006-10-30 07:21

This is relates to the issue 0003461
(0010395)
Arioch (developer)
2006-10-30 12:37

true.

I vote for checking in fix .SetRecNo, and then marking the rest of the ticket - duplicate of 0003461
(0013394)
obones (administrator)
2007-06-19 02:49

The change is in SVN

- Issue History
Date Modified Username Field Change
2006-10-29 14:12 Arioch New Issue
2006-10-29 16:27 Arioch File Added: Project1.exe
2006-10-29 16:28 Arioch File Added: MemoryDataset, GetRecNo in OnCalc.zip
2006-10-30 07:21 moore Note Added: 0010393
2006-10-30 12:37 Arioch Relationship added related to 0003461
2006-10-30 12:37 Arioch Note Added: 0010395
2007-06-19 02:49 obones Status new => resolved
2007-06-19 02:49 obones Fixed in Version => Daily / SVN
2007-06-19 02:49 obones Resolution open => fixed
2007-06-19 02:49 obones Assigned To => obones
2007-06-19 02:49 obones Note Added: 0013394


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker