Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003992 [JEDI VCL] 00 JVCL Components minor always 2006-11-08 06:09 2007-10-12 03:41
Reporter inver View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.10
Summary 0003992: TjvMainMenu, style = msXP on VISTA
Description Hi,

we are using the TJvMainMenu with .style := msXP.

On winXP, no problem. But on vista beta 2, the dispaly is wrong.
Additional Information Context:
We do NOT use the menu events, but we got an imageList.
we use XPManifest and the JEDI docking librairy.
JVCL 3.10
Win Vista beta 2

I know vista is not yet released, but i hope this report will help to fix the bug quicker.
Tags No tags attached.
Attached Files jpg file icon MainMenu_msXP_Vista.JPG [^] (6,512 bytes) 2006-11-08 06:09

- Relationships
parent of 0004146resolvedremkobonte JvMenus.TJvXPMenuItemPainter.DrawBorder 

-  Notes
(0010422)
obones (administrator)
2006-11-08 08:21

Here is the policy:

1. Vista is a beta
2. Microsoft promised compatibility
3. None of us have vista.

Well, it seems compatibility is not there, and I can't test it...
(0010423)
inver (reporter)
2006-11-08 08:47

thanks for your quick answer.

Well, i understand perfectly your policy. I just hope someone can have a look a this when Vista will be released.


Thanks for your work.
(0010424)
obones (administrator)
2006-11-08 08:52

Oh, and I see you use JVCL 3.10. It is quite old, please try a more recent.
(0013047)
edoardor (reporter)
2007-06-01 03:35

i have vista businnes release and the problem with the msXP style is:

the submenu appears correctly but a lot slowly
(0013135)
obones (administrator)
2007-06-04 09:31

Yep, we know, it's because we draw on the desktop. If anyone knows how to avoid this and still get the same effect...
(0013172)
remkobonte (developer)
2007-06-05 16:11

I now have MS Vista and can reproduce this problem with the EditorDemo in Examples\JvRichEdit.

I made some changes in JvMenus.pas. Please check if this fixes your problem and report back.
(0013180)
edoardor (reporter)
2007-06-06 01:27

where i can find the new JvMenu.pas ?

thanks
(0013182)
obones (administrator)
2007-06-06 02:49

Use SVN access or the daily zips: http://jvcl.sf.net/daily/ [^]
(0013888)
obones (administrator)
2007-10-12 03:40

I believe this is fixed.

- Issue History
Date Modified Username Field Change
2006-11-08 06:09 inver New Issue
2006-11-08 06:09 inver File Added: MainMenu_msXP_Vista.JPG
2006-11-08 08:21 obones Note Added: 0010422
2006-11-08 08:21 obones Status new => feedback
2006-11-08 08:47 inver Note Added: 0010423
2006-11-08 08:52 obones Note Added: 0010424
2007-06-01 03:32 edoardor Issue Monitored: edoardor
2007-06-01 03:35 edoardor Note Added: 0013047
2007-06-04 09:31 obones Note Added: 0013135
2007-06-05 16:11 remkobonte Note Added: 0013172
2007-06-06 01:27 edoardor Note Added: 0013180
2007-06-06 02:49 obones Note Added: 0013182
2007-06-07 17:23 remkobonte Relationship added parent of 0004146
2007-10-12 03:40 obones Status feedback => resolved
2007-10-12 03:40 obones Fixed in Version => Daily / SVN
2007-10-12 03:40 obones Resolution open => fixed
2007-10-12 03:40 obones Assigned To => obones
2007-10-12 03:40 obones Note Added: 0013888


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker