Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004013 [JEDI VCL] 00 JVCL Components minor always 2006-12-07 09:48 2008-07-23 07:18
Reporter ricolebo View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004013: TJvDBComboBox clear the value when exit
Description I join a project to show you the bug.

To correct this bug I have change procedure DataChange: It works but I don't know if it is correct (see additional information)

Thank you
Eric Guéguiniat
Additional Information procedure TJvCustomDBComboBox.DataChange(Sender: TObject);
begin
  if DroppedDown then
    Exit;
  if FDataLink.Field <> nil then
    ComboText := FDataLink.Field.AsString
  else
  if csDesigning in ComponentState then
    ComboText := Name
  else
    if FDataLink <> nil then <= My Change
      FDataLink.UpdateRecord;
    //ComboText := '';
end;
Tags No tags attached.
Attached Files zip file icon testCombo.zip [^] (1,295 bytes) 2006-12-07 09:48

- Relationships

-  Notes
(0013403)
obones (administrator)
2007-06-19 04:14

This is now in SVN
(0013422)
ricolebo (reporter)
2007-06-19 06:06

Hi Olivier,

I think that my change is not correct, because I don't keep it (cause a bug).
I don't remenber why, but I can find later If you want.

Eric
(0013895)
obones (administrator)
2007-10-12 04:16

Any news on this ?
(0014238)
obones (administrator)
2008-02-21 03:51

Hello? Any news?
(0014433)
obones (administrator)
2008-07-23 07:17

No news, no action

- Issue History
Date Modified Username Field Change
2006-12-07 09:48 ricolebo New Issue
2006-12-07 09:48 ricolebo File Added: testCombo.zip
2007-06-19 04:14 obones Status new => resolved
2007-06-19 04:14 obones Fixed in Version => Daily / SVN
2007-06-19 04:14 obones Resolution open => fixed
2007-06-19 04:14 obones Assigned To => obones
2007-06-19 04:14 obones Note Added: 0013403
2007-06-19 06:06 ricolebo Status resolved => feedback
2007-06-19 06:06 ricolebo Resolution fixed => reopened
2007-06-19 06:06 ricolebo Note Added: 0013422
2007-10-12 04:16 obones Note Added: 0013895
2008-02-21 03:51 obones Note Added: 0014238
2008-07-23 07:17 obones Status feedback => resolved
2008-07-23 07:17 obones Resolution reopened => fixed
2008-07-23 07:17 obones Note Added: 0014433


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker