Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004016 [JEDI VCL] 00 JVCL Components minor always 2006-12-11 16:15 2007-06-19 08:27
Reporter Traptak View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004016: Problem with loading docked forms using TJvAppDBStorage component
Description I have problem with loading saved docked form using TJvAppDBStorage. Calling LoadDockTreeFromAppStorage just don't works.
Additional Information I have solve this problem changing TJvCustomAppDBStorage.PathExistsInt.
I think it should looks like:
function TJvCustomAppDBStorage.PathExistsInt(const Path: string): Boolean;
begin
  { TODO -oJVCL -cTESTING : Is this correct implementation? }
  Result := SectionExists(StrEnsureNoPrefix('\', Path), True);
end;
Without StrEnsureNoPrefix function PathExistsInt always return False.
Tags No tags attached.
Attached Files ? file icon JvAppDBStorage.patch [^] (708 bytes) 2006-12-11 16:15

- Relationships

-  Notes
(0011269)
jfudickar (developer)
2007-03-02 15:57

Changed in SVN. Please have a look for it.
(0013459)
obones (administrator)
2007-06-19 08:26

No news, this is assumed to be fixed.

- Issue History
Date Modified Username Field Change
2006-12-11 16:15 Traptak New Issue
2006-12-11 16:15 Traptak File Added: JvAppDBStorage.patch
2006-12-13 10:50 jfudickar Issue Monitored: jfudickar
2007-03-02 15:55 jfudickar Status new => assigned
2007-03-02 15:55 jfudickar Assigned To => jfudickar
2007-03-02 15:57 jfudickar Note Added: 0011269
2007-03-02 15:57 jfudickar Status assigned => feedback
2007-06-19 08:26 obones Status feedback => resolved
2007-06-19 08:26 obones Fixed in Version => 3.31
2007-06-19 08:26 obones Resolution open => fixed
2007-06-19 08:26 obones Note Added: 0013459


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker