Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004038 [JEDI VCL] 00 JVCL Components minor always 2007-01-16 08:17 2007-01-27 14:06
Reporter maxp View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004038: JvRichEdit font assignment is incorrect when Font.Color = clWindowText
Description If JvRichEdit.Font.Color is set to clWindowText, assignment of font attributes is incorrect, for example the next operator

JvRichEdit1.SelAttributes.Assign(FontDialogInfo.Font);

will not change some text attributes unless you are also changing font color.

This is because of a bug in the line 6461, file JvRichEdit.pas, revision 11057:

 6460 if (Font.Color = clWindowText) or (Font.Color = clDefault) then
 6461 dwEffects := CFE_AUTOCOLOR

instead of "dwEffects := CFE_AUTOCOLOR" the line probably should be
            dwEffects := dwEffects or CFE_AUTOCOLOR



Additional Information The original source of JvRichEdit is RxEdit, there is the same bug in the last available version of RxLib (v.2.7.6), file RxRichEd.pas (http://sourceforge.net/projects/rxlib/) [^]
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0010680)
obones (administrator)
2007-01-27 14:05

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2007-01-16 08:17 maxp New Issue
2007-01-27 14:05 obones Status new => resolved
2007-01-27 14:05 obones Fixed in Version => Daily / SVN
2007-01-27 14:05 obones Resolution open => fixed
2007-01-27 14:05 obones Assigned To => obones
2007-01-27 14:05 obones Note Added: 0010680


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker