Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004108 [JEDI VCL] 00 JVCL Components minor always 2007-04-17 18:06 2007-04-19 15:55
Reporter Kiriakos View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004108: JvDocking and Windows Vista
Description There is a lot of flicker when you load docking layouts in Windows Vista. This is because that code that was introduced to deal with the same problem in Windows XP is not used in Vista.

Solution:
In JvDockControlForm.pas InitDockManager function define IsWinXP as follows:

    IsWinXP := (OSVersionInfo.dwMajorVersion > 5) or
      (OSVersionInfo.dwMajorVersion = 5) and (OSVersionInfo.dwMinorVersion >= 1);

You may want to rename IsWinXP to IsWinXPorNewer
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0012228)
remkobonte (developer)
2007-04-19 15:55

Thanks, this is now in revision 11271

- Issue History
Date Modified Username Field Change
2007-04-17 18:06 Kiriakos New Issue
2007-04-19 15:55 remkobonte Status new => resolved
2007-04-19 15:55 remkobonte Fixed in Version => Daily / SVN
2007-04-19 15:55 remkobonte Resolution open => fixed
2007-04-19 15:55 remkobonte Assigned To => remkobonte
2007-04-19 15:55 remkobonte Note Added: 0012228


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker