Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004140 [JEDI VCL] 00 JVCL Components minor always 2007-05-31 02:07 2007-06-03 19:04
Reporter bravecobra View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.30
Summary 0004140: TJvBackgroundLink has a memory leak
Description Using the FastMM4 library's FastMM_FullDebugMode.dll, I noticed it reporting a memory leak for TJvBackgroundLink. The report is attached.
As for the test project, I just made a new project in Delphi 7, added the FastMM4 units, set the compiler directives correctly so it would reportand dropped a TjvBackground on the form to which I assigned an image.
Additional Information
Tags No tags attached.
Attached Files txt file icon Project1_MemoryManager_EventLog.txt [^] (2,430 bytes) 2007-05-31 02:07

- Relationships

-  Notes
(0013120)
AHUser (developer)
2007-06-03 19:03

Fixed in SVN.

BTW: The attached stacktrace doesn't help because it has no function names in it. And the addresses are the one from your application.

- Issue History
Date Modified Username Field Change
2007-05-31 02:07 bravecobra New Issue
2007-05-31 02:07 bravecobra File Added: Project1_MemoryManager_EventLog.txt
2007-06-03 19:03 AHUser Status new => resolved
2007-06-03 19:03 AHUser Fixed in Version => Daily / SVN
2007-06-03 19:03 AHUser Resolution open => fixed
2007-06-03 19:03 AHUser Assigned To => AHUser
2007-06-03 19:03 AHUser Note Added: 0013120


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker