Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004146 [JEDI VCL] 00 JVCL Components crash always 2007-06-07 03:12 2007-06-09 10:24
Reporter Karlheinz View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004146: JvMenus.TJvXPMenuItemPainter.DrawBorder
Description I get an Error

Exception class: EInvalidOperation
Exception message: Canvas does not allow drawing.
in
JvMenus.TJvXPMenuItemPainter.DrawBorder (Line 3232, "JvMenus.pas" + 12)
with the actual SVN version on WinXPSP2 and Delphi2007Upd1.

Attached you will find the stack list and a screenshot where you can see how the painting looks like.

Regards Karlheinz
Additional Information
Tags No tags attached.
Attached Files txt file icon FehlerinJVMenue.txt [^] (15,214 bytes) 2007-06-07 03:12
jpg file icon Error Screenshot.JPG [^] (260,006 bytes) 2007-06-07 03:14

- Relationships
child of 0003992resolvedobones TjvMainMenu, style = msXP on VISTA 

-  Notes
(0013228)
remkobonte (developer)
2007-06-07 17:32

Thanks for the detailed report. I made some changes in Rev. 11314.

Please check it and report back...
(0013233)
Karlheinz (reporter)
2007-06-08 00:50

I must say thank you for the fast solution of the problem.

I tried every menu of my application and did not get any error.
I think the problem is solved.

Regards Karlheinz
(0013260)
remkobonte (developer)
2007-06-09 10:22

Okay, thanks for the feedback.

- Issue History
Date Modified Username Field Change
2007-06-07 03:12 Karlheinz New Issue
2007-06-07 03:12 Karlheinz File Added: FehlerinJVMenue.txt
2007-06-07 03:14 Karlheinz File Added: Error Screenshot.JPG
2007-06-07 13:45 remkobonte Status new => assigned
2007-06-07 13:45 remkobonte Assigned To => remkobonte
2007-06-07 17:23 remkobonte Relationship added child of 0003992
2007-06-07 17:32 remkobonte Note Added: 0013228
2007-06-07 17:33 remkobonte Status assigned => feedback
2007-06-08 00:50 Karlheinz Note Added: 0013233
2007-06-09 10:22 remkobonte Status feedback => resolved
2007-06-09 10:22 remkobonte Fixed in Version => Daily / SVN
2007-06-09 10:22 remkobonte Resolution open => fixed
2007-06-09 10:22 remkobonte Note Added: 0013260


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker