Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004147 [JEDI VCL] 00 JVCL Components minor always 2007-06-08 11:48 2007-06-28 03:01
Reporter ricardona View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004147: jvInspector, check ADataObj.TypeInfo
Description Sometimes ADataObj.TypeInfo is not assigned, is necessary check, look additional data for patch file.
Additional Information Index: JvInspector.pas

===================================================================

--- JvInspector.pas (revision 11313)

+++ JvInspector.pas (working copy)

@@ -12727,7 +12727,8 @@

   if ADataObj.TypeInfo = TypeInfo then
     Result := 100
   else
- if (TypeInfo.Kind = tkClass) and (ADataObj.TypeInfo.Kind = tkClass) and
+ if Assigned(ADataObj.TypeInfo) and (TypeInfo.Kind = tkClass) and
+ (ADataObj.TypeInfo.Kind = tkClass) and
     (GetTypeData(ADataObj.TypeInfo).ClassType.InheritsFrom(GetTypeData(TypeInfo).ClassType)) then
     Result := 50
   else
@@ -12800,7 +12801,7 @@

 
 function TJvInspectorTypeKindRegItem.MatchValue(const ADataObj: TJvCustomInspectorData): Integer;
 begin
- if ADataObj.TypeInfo.Kind = TypeKind then
+ if Assigned(ADataObj.TypeInfo) and (ADataObj.TypeInfo.Kind = TypeKind) then
     Result := 100
   else
     Result := 0;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0013259)
obones (administrator)
2007-06-09 09:32

Under which conditions do you get a nil TypeInfo?
(0013541)
ricardona (reporter)
2007-06-27 23:41

I cant reproduce with the SVN version! please close the issue. thanks
(0013542)
obones (administrator)
2007-06-28 03:01

As indicated by ricardona

- Issue History
Date Modified Username Field Change
2007-06-08 11:48 ricardona New Issue
2007-06-09 09:32 obones Note Added: 0013259
2007-06-09 09:32 obones Status new => feedback
2007-06-27 23:41 ricardona Note Added: 0013541
2007-06-28 03:01 obones Status feedback => resolved
2007-06-28 03:01 obones Fixed in Version => Daily / SVN
2007-06-28 03:01 obones Resolution open => fixed
2007-06-28 03:01 obones Assigned To => obones
2007-06-28 03:01 obones Note Added: 0013542


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker