Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004181 [JEDI VCL] 00 JVCL Components major random 2007-07-17 07:32 2007-08-18 07:24
Reporter mlemanczyk View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004181: JvXPButton click raised twice
Description I believe this is the same issue as 0003327. I can see this happening in 3.31, 3.32 & trunk SVN source codes.

It's completely random. Happens to some buttons, doesn't happen to others. Basically I have JvXPButtons with:
  - glyph assigned
  - regular action assigned

Assigned action is not a problem. It happens also when no action is assigned, just OnClick.

In OnClick I'm calling MessageBox function, using Handle of the form, e.g.
  MessageBox(Handle, 'Test', 'Test', MB_YESNO);

Now:
1) click on JvXPButton and DON'T MOVE your mouse
2) wait for message box to show up
3) press N key - don't click anything with mouse!
4) same message box shows up

Another test:
1) click on JvXPButton and MOVE your mouse out of the button
2) wait for message box to show up
3) press N key - don't click anything with mouse!
4) window closes - move your mouse over JvXPButton - it goes down indicating that you keep your mouse button down (which is not true)

JvXPButton doesn't recognize that a mouse button was released. When I move mouse over it, it goes down. I tried to put ReleaseCapture() call in MouseDown handle, but it didn't help.

I tried to reproduce it in a new application, but I can't see it happening. Basically, the XpButtons are placed on a JvXPContainer, which is on a JvPanel control. I believe the other controls don't impact JvXPButton behavior.

It's quite important, since it affects the end user.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0013642)
AHUser (developer)
2007-08-18 07:23

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2007-07-17 07:32 mlemanczyk New Issue
2007-08-18 07:23 AHUser Status new => resolved
2007-08-18 07:23 AHUser Fixed in Version => Daily / SVN
2007-08-18 07:23 AHUser Resolution open => fixed
2007-08-18 07:23 AHUser Assigned To => AHUser
2007-08-18 07:23 AHUser Note Added: 0013642


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker