Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004257 [JEDI VCL] 00 JVCL Components minor always 2007-10-04 09:32 2007-10-31 05:12
Reporter dejoy View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004257: Donate JvJCLUtils and JvJVCLUtils
Description Improve procedure of DrawArrow .

JvJCLUtils
  add function RectIsSquare // copy for JclGraphUtils
  add procedure RectNormalize // copy for JclGraphUtils
  add function RectSquare

JvJVCLUtils
  Rewrite procedure DrawArrow ,add al param Margin ,Added a same name DrawArrow overload,
   Thus you can draw arrow by Point + Size now, not just only by rect.
 
Additional Information
Tags No tags attached.
Attached Files rar file icon JvJCLUtils.rar [^] (99,473 bytes) 2007-10-04 09:32

- Relationships

-  Notes
(0013949)
obones (administrator)
2007-10-12 09:09

Thanks, we'll look at this when we get free time
(0013990)
AHUser (developer)
2007-10-21 10:02

The JvJVCLUtils.DrawArrow() function seems to be incorrect. The local "Size" variable isn't initialized but used in "if Odd(Size) then" and then later overwritten by "Size := RectWidth(ARect);". What was/is the purpose of this if-statement. Is it a testing relict?
(0014011)
AHUser (developer)
2007-10-31 05:12

Added to SVN

- Issue History
Date Modified Username Field Change
2007-10-04 09:32 dejoy New Issue
2007-10-04 09:32 dejoy File Added: JvJCLUtils.rar
2007-10-12 09:09 obones Note Added: 0013949
2007-10-12 09:09 obones Status new => acknowledged
2007-10-21 10:02 AHUser Note Added: 0013990
2007-10-21 10:02 AHUser Assigned To => AHUser
2007-10-21 10:02 AHUser Status acknowledged => feedback
2007-10-21 10:08 AHUser Issue Monitored: AHUser
2007-10-31 05:12 AHUser Status feedback => resolved
2007-10-31 05:12 AHUser Fixed in Version => Daily / SVN
2007-10-31 05:12 AHUser Resolution open => fixed
2007-10-31 05:12 AHUser Note Added: 0014011
2007-12-16 11:20 AHUser Issue End Monitor: AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker