Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004269 [JEDI VCL] 00 JVCL Components minor always 2007-10-19 21:29 2007-10-24 01:51
Reporter Peter Batten View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004269: TJvSelectDirectory OnShow, OnClose do not fire
Description TJvSelectDirectory OnShow, OnClose do not fire in release 3.33

Tested in Vista and Win 2K

This was reported fixed see 0004203
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0013992)
AHUser (developer)
2007-10-23 11:35

Interesting.

This is the current code (last modified 2007-08-18).

function TJvSelectDirectory.Execute: Boolean;
begin
  FDirectory := InitialDir;
  DoShow; // <<-- this is always executed
  try
    if ClassicDialog then
      Result := SelectDirectory(FDirectory, Options, HelpContext)
    else
      Result := SelectDirectory(Title, InitialDir, FDirectory);
  finally
    DoClose; // <<-- and this is also always executed
  end;
end;


Unfortunatelly this could hasn't made it into the 3.33 release. I don't know why because 3.33 was released on 2007-09-19 (one month after I made this code change).
You can either use the SVN head or the binary precompiled JVCL 3.33
http://jvcl.sourceforge.net/websetup/jvcl/ [^]
which was built on 2007-10-03 from the SVN head.
(0013993)
obones (administrator)
2007-10-24 01:50

3.33 was made from a branch created before the changed was put in SVN, hence the reason this particular change is not in it.

- Issue History
Date Modified Username Field Change
2007-10-19 21:29 Peter Batten New Issue
2007-10-23 11:35 AHUser Note Added: 0013992
2007-10-23 11:35 AHUser Status new => feedback
2007-10-24 01:50 obones Status feedback => resolved
2007-10-24 01:50 obones Fixed in Version => Daily / SVN
2007-10-24 01:50 obones Resolution open => fixed
2007-10-24 01:50 obones Assigned To => obones
2007-10-24 01:50 obones Note Added: 0013993


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker