Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004275 [JEDI VCL] 00 JVCL Components crash always 2007-10-24 10:06 2007-12-24 16:15
Reporter delphiprog View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004275: Affecting property FileName in TJvAppIniFileStorage or TJvAppXMLFileStorage causes BCB5 to crash at design time
Description Affecting a string at design time to the property FileName of a TJvAppIniFileStorage or a TJvAppXMLFileStorage causes Builder 5 to crash and close immediatly.

Trying to do the same thing at runtime causes an AV.
Additional Information These components run correctly under Delphi 7.

Cause of the problem :
TJvCustomAppMemoryFileStorage owns a property FileName declared as public.
TJvAppIniFileStorage and TJvXMLFileSTorage redeclares this property but as published.
BCB5 seems to be troubled.

The solution I've found :
1- Declare FileName as a published property in TJvCustomAppMemoryFileStorage instead of public (line 846).
2- Recompile every package with the (great !) install.bat located in the jvcl directory.

Now, these components work very well in BCB5 and D7.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014097)
obones (administrator)
2007-12-24 12:01

I see this as well. Trying to figure out exactly why this is happening.
(0014098)
obones (administrator)
2007-12-24 12:04

This is very strange as TJvFtpUrlGrabber proposes the same sort of interface and does not crash BCB5. Don't understand why yet.
(0014099)
obones (administrator)
2007-12-24 12:22

Ok, the problem is with the call to ActiveTranslateStringEngine inside TJvCustomAppMemoryFileStorage.RecalculateFullFileName
(0014100)
obones (administrator)
2007-12-24 16:14

This is now fixed in SVN (revision 11642).

- Issue History
Date Modified Username Field Change
2007-10-24 10:06 delphiprog New Issue
2007-12-24 12:01 obones Note Added: 0014097
2007-12-24 12:01 obones Status new => confirmed
2007-12-24 12:04 obones Note Added: 0014098
2007-12-24 12:22 obones Note Added: 0014099
2007-12-24 16:14 obones Status confirmed => resolved
2007-12-24 16:14 obones Fixed in Version => Daily / SVN
2007-12-24 16:14 obones Resolution open => fixed
2007-12-24 16:14 obones Assigned To => obones
2007-12-24 16:14 obones Note Added: 0014100


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker