Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004299 [JEDI VCL] 00 JVCL Components minor always 2007-12-03 03:48 2007-12-16 06:19
Reporter klausvod View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004299: JvDBSpinEdit - FocusKilled - OnEdit gets fired
Description Hello there!

I have (next to other DB controls) a JvDBSpinEdit connected (via DataSource)
to an integer field returned by an ADOQuery.
If JvDBSpinEdit is focused when posting the record on exiting that control
(independently from post) the ADOQuery.OnEdit event gets fired.
In the callstack the line prior to ...AfterEdit is
TJvCustomSpinEdit.FocusKilled .

To me this behaviour seems to be a bug, isn't it?

When eliminating coCheckOnExit from CheckOptions everything is OK. It's
interesting that this makes difference since I have CheckMinValue and
CheckMaxValue both set to false ...

Regards,

klaus
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014054)
AHUser (developer)
2007-12-16 06:19

There seems to be a design problem with the SpinEdit that makes it hard for a DB-aware component. I have fixed it by testing for Field.Value <> NewValue.

- Issue History
Date Modified Username Field Change
2007-12-03 03:48 klausvod New Issue
2007-12-16 06:19 AHUser Status new => resolved
2007-12-16 06:19 AHUser Fixed in Version => Daily / SVN
2007-12-16 06:19 AHUser Resolution open => fixed
2007-12-16 06:19 AHUser Assigned To => AHUser
2007-12-16 06:19 AHUser Note Added: 0014054


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker