Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004323 [JEDI VCL] 00 JVCL Components minor always 2007-12-24 23:17 2008-07-23 07:21
Reporter EinWill View Status public  
Assigned To obones
Priority normal Resolution duplicate  
Status resolved   Product Version 3.32
Summary 0004323: TJvCaptionButton positioning fails in Windows Vista
Description If running under Windows Vista TJvCaptionButton is placed wrongly on caption bar. Say, if JvCaptionButton1.Standrad = tsbNone and JvCaptionButton1.Position = 0 then the button appears somewhere between "minimize" and "maximize" buttons, while it should be placed next to the left most default caption button.

This is not to mentioned that it fails to draw the button in Vista-style ;)

Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0004398resolvedAHUser TJvCpationButton does not work correctly in Windows Vista 

-  Notes
(0014185)
obones (administrator)
2008-02-20 09:20

JvCaptionButton is not meant to support themes at all. If you find a way to get the current style then draw and position the caption button correctly, please let us know and post your modifications as an attachment here.

- Issue History
Date Modified Username Field Change
2007-12-24 23:17 EinWill New Issue
2008-02-20 09:20 obones Note Added: 0014185
2008-02-20 09:20 obones Status new => feedback
2008-07-23 07:20 obones Relationship added duplicate of 0004398
2008-07-23 07:20 obones Duplicate ID 0 => 4398
2008-07-23 07:20 obones Status feedback => resolved
2008-07-23 07:20 obones Resolution open => duplicate
2008-07-23 07:20 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker