Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004328 [JEDI VCL] 00 JVCL Components minor always 2008-01-05 04:17 2009-07-03 17:15
Reporter damian_lisu View Status public  
Assigned To wpostma416
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004328: Filter on TJvMemoryData dont work
Description It`s the same problem -> http://homepages.borland.com/jedi/issuetracker/view.php?id=2944 [^]
Quote "When I set filter on JvMemoryData component, the filter cannot apply."
Additional Information
Tags No tags attached.
Attached Files zip file icon JvMemoryDatasetWithFilter.zip [^] (23,233 bytes) 2009-05-18 18:43
zip file icon MemoryDataFilterDemo.zip [^] (445,546 bytes) 2009-06-08 16:18

- Relationships
related to 0002944resolvedobones Filter not function on JvMemoryData component 

-  Notes
(0014187)
obones (administrator)
2008-02-20 09:28

Well, yes, same answer then. It's not implemented. Please have a look at doing it and once your changes are ready, please provide them here.
Thanks in advance.
(0014436)
obones (administrator)
2008-07-23 07:19

No news, no action
(0014934)
CSchiffler (developer)
2008-10-31 02:03

Started Implementation.
(0015137)
obones (administrator)
2008-12-22 04:33

Please let us know when it's ready.
(0015494)
obones (administrator)
2009-04-29 16:49

Any news?
(0015500)
CSchiffler (developer)
2009-04-29 23:25

I totally forgot about this bug here... Sorry.
The source in the attached zip works, but is not the most up to date code.
I will wrap together my current source within the next days and again attach it here as I lack commit access to the source repos.
(0015527)
CSchiffler (developer)
2009-05-18 18:44

Ok, here it is.

TJvMemoryDataset with filtering capabilities.
Please diff the content of the attached zip file against the current stable version of JVCL as it was created using an ancient version (3.31.0.0).

The Filtering should work out of the box and handle almost any kind of logical expression.

The Code for the ExpressionParser (and evaluator) is based upon code by Vlad Skarzhevskyy released under GPL but Vlad Skarzhevskyy gave permission to re-release the code under MPL.
See copyright notice in ExprParser.pas for more details.

Currently there is onle one known issue:
  The equality check (foo='bar') is case insensitive due to usage of TMask class in unit Masks.

The Expression parser supports the following operators:
  + addition
  - substraction
  / division
  * multiplication
  < less than
  > greater than
  & boolean "and" operator
  AND alias for &
  | boolean "or" operator
  OR alias for |
  ! boolean "not"

It supports correct paranthesis matching.

Therefore it should support almost any BDE compatible expression that it get's fed with.

Hope you all like it
    Christian Schiffler
(0015606)
obones (administrator)
2009-06-04 17:00

Should not have been set to "resolved" by non developper account
(0015616)
wpostma416 (developer)
2009-06-05 22:56
edited on: 2009-06-05 22:59

Warren is currently attempting a merge. THe source code provided in the zip is from a pretty old JVCL (pre delphi 2009 changes) so the merge is non-trivial.
I am sure I can do it though.

Will rename new contributed code unit from ExprParser.pas to JvExprParser.pas..

(0015629)
wpostma416 (developer)
2009-06-08 16:22

Merged, demo program attached (see ZIP file attached).

SVN checkin revision: 12331
(0015758)
obones (administrator)
2009-07-03 17:15

Well then, this is fixed

- Issue History
Date Modified Username Field Change
2008-01-05 04:17 damian_lisu New Issue
2008-02-20 09:28 obones Note Added: 0014187
2008-02-20 09:28 obones Status new => feedback
2008-07-23 07:19 obones Status feedback => resolved
2008-07-23 07:19 obones Resolution open => suspended
2008-07-23 07:19 obones Assigned To => obones
2008-07-23 07:19 obones Note Added: 0014436
2008-10-31 02:03 CSchiffler Assigned To obones => CSchiffler
2008-10-31 02:03 CSchiffler Status resolved => feedback
2008-10-31 02:03 CSchiffler Resolution suspended => reopened
2008-10-31 02:03 CSchiffler Note Added: 0014934
2008-10-31 02:06 CSchiffler File Added: JvMemoryDatasetWithFilter.zip
2008-11-03 02:18 obones Relationship added related to 0002944
2008-12-22 04:33 obones Note Added: 0015137
2008-12-22 04:33 obones Status feedback => acknowledged
2009-04-29 16:49 obones Note Added: 0015494
2009-04-29 16:49 obones Status acknowledged => feedback
2009-04-29 23:25 CSchiffler Note Added: 0015500
2009-05-18 18:42 CSchiffler File Deleted: JvMemoryDatasetWithFilter.zip
2009-05-18 18:43 CSchiffler File Added: JvMemoryDatasetWithFilter.zip
2009-05-18 18:44 CSchiffler Note Added: 0015527
2009-05-18 18:44 CSchiffler Status feedback => resolved
2009-05-18 18:44 CSchiffler Resolution reopened => fixed
2009-06-02 19:38 Zento Issue Monitored: Zento
2009-06-04 15:38 wpostma416 Issue Monitored: wpostma416
2009-06-04 17:00 obones Assigned To CSchiffler => wapostma
2009-06-04 17:00 obones Note Added: 0015606
2009-06-04 17:00 obones Status resolved => feedback
2009-06-04 17:00 obones Resolution fixed => reopened
2009-06-05 22:56 wpostma416 Note Added: 0015616
2009-06-05 22:56 wpostma416 Assigned To wapostma => wpostma416
2009-06-05 22:59 wpostma416 Note Edited: 0015616
2009-06-08 16:18 wpostma416 File Added: MemoryDataFilterDemo.zip
2009-06-08 16:22 wpostma416 Note Added: 0015629
2009-07-03 17:15 obones Note Added: 0015758
2009-07-03 17:15 obones Status feedback => resolved
2009-07-03 17:15 obones Fixed in Version => 3.37
2009-07-03 17:15 obones Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker