Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004349 [JEDI VCL] 00 JVCL Components minor always 2008-02-21 07:47 2008-03-05 08:01
Reporter franklinhaut View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004349: JVMenu D7 "Canvas does not allow drawing"
Description After upgrading to last revision the error persist, same case at Mantis 0004347

a new screenshot attached

if you need I can dispose more data or a WTS conection.
(send me a mail to franklin.haut@gmail.com )



Additional Information
Tags No tags attached.
Attached Files jpg file icon error5.JPG [^] (80,836 bytes) 2008-02-21 07:47

- Relationships

-  Notes
(0014262)
franklinhaut (reporter)
2008-02-21 08:00

wait, is something wrong where, a can´t reproduce again... return the issue to me.
(0014263)
obones (administrator)
2008-02-21 08:23

Please try adding back DCX_CACHE in the call to GetDCEx and let me know if this helps.
(0014264)
obones (administrator)
2008-02-21 08:58

Ah ok
(0014265)
franklinhaut (reporter)
2008-02-21 10:05

Hi,

the error occurs again, using DCX_CACHE the menus are wrong painted

I produced the video to show whats happen in the two situations

http://giro.no-ip.info:8000/JVMenuError/JVMenuError.html [^]
(0014271)
obones (administrator)
2008-03-04 04:31

Can you tell me if it works with the very latest SVN version?
(0014275)
franklinhaut (reporter)
2008-03-04 18:45

Using the revision 11747 (last at moment), and patching file on 0004352 the problem continues... can i help with some more information ?


ps.: its possible get a commit user on SVN to help on small implementations ?
(0014281)
franklinhaut (reporter)
2008-03-05 06:00

I build a executable on my machine and does not work (same message "Canvas does not allow drawing") then i copy the same executable to another machine using XP too, and the message doesn't appear.


After removing the implementation on JVMenus lines 3688~3705 that work in the two machines...

source removed:
          DC := GetDCEx(CanvasWindow, 0, (*DCX_CACHE or *)DCX_WINDOW);
          try
            if not Assigned(FBorderCanvas) then
            begin
              LastError := GetLastError;
              if (DC = 0) and (LastError = ERROR_SUCCESS) then
                FBorderCanvas := TJvDesktopCanvas.Create
              else
                FBorderCanvas := TControlCanvas.Create;
              FBorderCanvas.Handle := DC;
            end;

            if FBorderCanvas.Handle <> DC then
              FBorderCanvas.Handle := DC;
            DrawBorder(FBorderCanvas, WRect);
          finally
            ReleaseDC(CanvasWindow, DC);
          end;
(0014282)
obones (administrator)
2008-03-05 07:12

Yes, but removing this you no longer have the borders.
However, I think you can solve the problem by putting back the code then remove this

              if (DC = 0) and (LastError = ERROR_SUCCESS) then
                FBorderCanvas := TJvDesktopCanvas.Create
              else
                FBorderCanvas := TControlCanvas.Create;


and replace with this
              FBorderCanvas := TJvDesktopCanvas.Create;

That should solve the problem on both your machines.
(0014283)
franklinhaut (reporter)
2008-03-05 07:33

yes, thats works in all machines, you can commit this changes ?
(0014284)
obones (administrator)
2008-03-05 08:01

The changes are now in SVN

- Issue History
Date Modified Username Field Change
2008-02-21 07:47 franklinhaut New Issue
2008-02-21 07:47 franklinhaut File Added: error5.JPG
2008-02-21 08:00 franklinhaut Note Added: 0014262
2008-02-21 08:23 obones Note Added: 0014263
2008-02-21 08:23 obones Status new => feedback
2008-02-21 08:58 obones Status feedback => resolved
2008-02-21 08:58 obones Resolution open => unable to reproduce
2008-02-21 08:58 obones Assigned To => obones
2008-02-21 08:58 obones Note Added: 0014264
2008-02-21 10:05 franklinhaut Status resolved => feedback
2008-02-21 10:05 franklinhaut Resolution unable to reproduce => reopened
2008-02-21 10:05 franklinhaut Note Added: 0014265
2008-03-04 04:31 obones Note Added: 0014271
2008-03-04 18:45 franklinhaut Note Added: 0014275
2008-03-05 05:59 franklinhaut Note Added: 0014280
2008-03-05 06:00 franklinhaut Note Added: 0014281
2008-03-05 06:01 franklinhaut Note Deleted: 0014280
2008-03-05 07:12 obones Note Added: 0014282
2008-03-05 07:33 franklinhaut Note Added: 0014283
2008-03-05 08:01 obones Status feedback => resolved
2008-03-05 08:01 obones Fixed in Version => Daily / SVN
2008-03-05 08:01 obones Resolution reopened => fixed
2008-03-05 08:01 obones Note Added: 0014284


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker