Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004354 [JEDI VCL] 00 JVCL Components minor always 2008-03-06 02:58 2008-05-28 13:20
Reporter martinalex View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004354: JvHTMLParser attributes never shown
Description The JvHTMLParser does not show any attributes.

E.g. when running the JVCL sample JvHtmlParserProj.exe with the sample file ‘sample.htm’ from \jvcl\examples\JvHTMLParser
Attributes are never shown

For the tag (Line 4 in the sample file)
<Table Width="100%" Border=1 BgColor="#ffffcc">

the sample program shows the tag, on tab 4 ‘tags’
    <Table Width="100%" Border=1 BgColor="#ffffcc">
But no attributes.
It should show
  Attributes:
  Width="100%"
  Border=1
  BgColor="#ffffcc"


The problem is that in JvHTMLParser.pas
procedure TJvHTMLParser.AnalyseString
the procedure ParseAttributes(AttributesList, Str3);
is called with Str3, but Str3 is always empty.
the empty list is passed to FOnKeyFoundEx()

The fix is to use Str2 instead
    ParseAttributes(AttributesList, Str2);

Perhaps Str3 could be used if not empty
        if Str3<>'' then
           ParseAttributes(AttributesList, Str3)
        else
           ParseAttributes(AttributesList, Str2);

There was a similar issue in 2006, 0003489, which was closed, because no sample was given.


Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014310)
obones (administrator)
2008-05-28 13:20

This is fixed in SVN

- Issue History
Date Modified Username Field Change
2008-03-06 02:58 martinalex New Issue
2008-03-06 03:02 martinalex Issue Monitored: martinalex
2008-05-28 13:20 obones Status new => resolved
2008-05-28 13:20 obones Fixed in Version => Daily / SVN
2008-05-28 13:20 obones Resolution open => fixed
2008-05-28 13:20 obones Assigned To => obones
2008-05-28 13:20 obones Note Added: 0014310


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker