Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004372 [JEDI VCL] 00 JVCL Components crash random 2008-06-07 08:13 2008-06-22 13:39
Reporter saidus View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004372: Memory Leak
Description Hello All !!,
I've Inherited a Button (works with DB) from TJvTransparentButton and put it in a BPL (RunTime ) then Create a small application using it ..
I've allways receive an error message (Error accessing memory 0x23565232...)
I've used the memproof Utilitie with my little application then I've found that
the JvCoreD7, JCL, JclVCL ans many others allocate a memory but don't free it
the probleme is essencially with the the TJvTransparentButton.
Thanks
(I will try to reproduce a little exemple then send it to you)
Additional Information
Tags No tags attached.
Attached Files zip file icon errjVCL.zip [^] (174,706 bytes) 2008-06-07 08:13
rar file icon testJVCL.rar [^] (172,559 bytes) 2008-06-17 05:21
? file icon JvTransparentButton.pas [^] (40,065 bytes) 2008-06-22 08:24

- Relationships
has duplicate 0004933resolvedobones Memoryleak in TJvTransparentButton 

-  Notes
(0014337)
obones (administrator)
2008-06-16 07:32

Then we are waiting for the simple application
(0014338)
saidus (reporter)
2008-06-17 02:17

In this file you find an Exemple with source code to view the well the problem
I've used __Eurekalog to catch well the memory leak
ps : I use Delphi7 and JVCL 333
you can also view the file Project1.elf for more detail
Thanks..
(0014339)
saidus (reporter)
2008-06-17 02:55

I don't know why i can't send the archive file.
this is the message i receive in my web browser :

APPLICATION ERROR 0000200
A required parameter to this page (bug_id) was not found.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
(0014340)
obones (administrator)
2008-06-17 04:15

Likely because it is too big. Just give the sources, no dcu, no exe
(0014341)
saidus (reporter)
2008-06-17 05:21

Ok I've Send the sources
(0014345)
saidus (reporter)
2008-06-22 00:00

so !!!
did you see the problem ????
(0014346)
saidus (reporter)
2008-06-22 08:30

I think I have resolved the problem ..
See in the uploded JvTransparentButton.pas
the destuctor :
destructor TJvTransparentButton.Destroy;
(0014347)
AHUser (developer)
2008-06-22 13:38

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2008-06-07 08:13 saidus New Issue
2008-06-07 08:13 saidus File Added: errjVCL.zip
2008-06-07 08:15 saidus Issue Monitored: saidus
2008-06-16 07:32 obones Note Added: 0014337
2008-06-16 07:32 obones Status new => feedback
2008-06-17 02:17 saidus Note Added: 0014338
2008-06-17 02:51 saidus Issue End Monitor: saidus
2008-06-17 02:55 saidus Note Added: 0014339
2008-06-17 04:15 obones Note Added: 0014340
2008-06-17 05:21 saidus File Added: testJVCL.rar
2008-06-17 05:21 saidus Note Added: 0014341
2008-06-17 07:13 saidus Issue Monitored: saidus
2008-06-22 00:00 saidus Note Added: 0014345
2008-06-22 08:25 saidus File Added: JvTransparentButton.pas
2008-06-22 08:30 saidus Note Added: 0014346
2008-06-22 13:38 AHUser Status feedback => resolved
2008-06-22 13:38 AHUser Fixed in Version => Daily / SVN
2008-06-22 13:38 AHUser Resolution open => fixed
2008-06-22 13:38 AHUser Assigned To => AHUser
2008-06-22 13:38 AHUser Note Added: 0014347
2009-09-22 15:35 obones Relationship added has duplicate 0004933


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker