Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004376 [JEDI VCL] 00 JVCL Components major always 2008-06-17 15:21 2008-06-21 04:06
Reporter USchuster View Status public  
Assigned To USchuster
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004376: JvDBImage: Loading images by TBitmap descendants does not work with Delphi 5
Description With Delphi 5 for example loading a PNG with TPNGGraphic from GraphicEx does not work.
Additional Information The problem is that the constructor of TPNGGraphic is not executed. (With Delphi 6 or 2007 it works.)

It works if you use "class of TBitmap" instead of "TGraphicClass = class of TGraphic" in TJvDBImage.AssignGraphicTo.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014344)
USchuster (manager)
2008-06-21 04:06

Fixed in revision 11815.

- Issue History
Date Modified Username Field Change
2008-06-17 15:21 USchuster New Issue
2008-06-17 15:21 USchuster Status new => assigned
2008-06-17 15:21 USchuster Assigned To => USchuster
2008-06-21 04:06 USchuster Status assigned => resolved
2008-06-21 04:06 USchuster Fixed in Version => Daily / SVN
2008-06-21 04:06 USchuster Resolution open => fixed
2008-06-21 04:06 USchuster Note Added: 0014344


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker