Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004381 [JEDI VCL] 00 JVCL Components minor always 2008-06-23 16:54 2008-06-28 08:05
Reporter nestor View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0004381: Tjvdbgrid scroll using wheel mouse
Description Jvdbgrid scroll behaviour is wrong when wheel mouse is used.
There is no scroll problem when the “alternaterowcolor” property is set to another color than “clNone”.

Additional Information
Tags No tags attached.
Attached Files zip file icon jvdbgrid.zip [^] (8,130 bytes) 2008-06-26 16:47

- Relationships

-  Notes
(0014348)
nestor (reporter)
2008-06-24 14:52

This problem occures since revision 11798
(0014349)
nestor (reporter)
2008-06-24 18:58

scroll problems can be fixed by removing the scroll switch sentences from this procedure.
procedure TJvDBGrid.MouseWheelHandler(var Message: TMessage);
var
  LastRow: Integer;
begin
// DisableScroll;
// try
    LastRow := Row;
    inherited MouseWheelHandler(Message);
    if (Row <> LastRow) and (DataLink <> nil) and DataLink.Active then
      InvalidateCell(IndicatorOffset - 1, LastRow);
// finally
// EnableScroll;
// end;
end;
(0014350)
obones (administrator)
2008-06-25 01:25

Please provide the zipped sources of a sample application showing this.
(0014354)
AHUser (developer)
2008-06-28 08:05

I hope this change doesn't break any older bug fix. I've added the DisableScroll/EnableScroll in my last bug fix because I ran into a bug if they were missing. Unfortunately I don't remember what this bug was and if the actual cause for the problem was fixed in a newer revision than the one I have at work.

- Issue History
Date Modified Username Field Change
2008-06-23 16:54 nestor New Issue
2008-06-24 14:52 nestor Note Added: 0014348
2008-06-24 18:59 nestor Note Added: 0014349
2008-06-25 01:25 obones Note Added: 0014350
2008-06-25 01:25 obones Status new => feedback
2008-06-26 16:47 nestor File Added: jvdbgrid.zip
2008-06-28 08:05 AHUser Status feedback => resolved
2008-06-28 08:05 AHUser Fixed in Version => Daily / SVN
2008-06-28 08:05 AHUser Resolution open => fixed
2008-06-28 08:05 AHUser Assigned To => AHUser
2008-06-28 08:05 AHUser Note Added: 0014354


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker