Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004412 [JEDI VCL] 00 JVCL Components minor always 2008-08-01 03:08 2008-11-02 12:40
Reporter mcurko View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.33
Summary 0004412: unit jvMemoryDataset
Description under Borland Developer Studio 2006
procedure TJvMemoryData.DataConvert crashed if I use TWideStringField.
If I to Stop Working this (use inherited), work normaly.

Crash on call SetString ... Dest^ - bad pointer or type ???

....exe raised exception class EAccessViolation message 'Access violation address 771544F1 in module oleaut32.dll. Read adress 000FFFC.
Additional Information procedure TJvMemoryData.DataConvert(Field: TField; Source, Dest: Pointer; ToNative: Boolean);
begin
  //mcurko - crash on SetString...
{ if Field.DataType = ftWideString then
  begin
    if ToNative then
    begin
      Word(Dest^) := Length(PWideString(Source)^) * 2;
      Move(PWideChar(Source^)^, (PWideChar(Dest) + 1)^, Word(Dest^));
    end
    else
      begin
         SetString(WideString(Dest^), PWideChar(PChar(Source) + 2), Word(Source^) div 2);
      end;
  end
  else}
    inherited DataConvert(Field, Source, Dest, ToNative);
end;
Tags No tags attached.
Attached Files ? file icon JvMemoryDataset.pas [^] (75,874 bytes) 2008-08-01 03:08

- Relationships
duplicate of 0004285resolvedAHUser TJvMemoryData causes access violation when assigning a WideString value to a TWideStringField 

-  Notes
(0014532)
obones (administrator)
2008-09-03 09:22

So you don't understand a problem and you comment out the code that shows it?
Nice... Seriously, this code is here because it is needed to handle widestrings. Better fix than make another bug reappear...
(0014811)
obones (administrator)
2008-10-10 05:06

Any proposition ?
(0014951)
AHUser (developer)
2008-11-02 12:40

Already fixed in version 3.35

- Issue History
Date Modified Username Field Change
2008-08-01 03:08 mcurko New Issue
2008-08-01 03:08 mcurko File Added: JvMemoryDataset.pas
2008-09-03 09:22 obones Note Added: 0014532
2008-09-03 09:22 obones Status new => feedback
2008-10-10 05:06 obones Note Added: 0014811
2008-11-02 12:34 AHUser Relationship added duplicate of 0004285
2008-11-02 12:40 AHUser Status feedback => resolved
2008-11-02 12:40 AHUser Fixed in Version => 3.35
2008-11-02 12:40 AHUser Resolution open => fixed
2008-11-02 12:40 AHUser Assigned To => AHUser
2008-11-02 12:40 AHUser Note Added: 0014951


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker