Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004442 [JEDI VCL] 00 JVCL Components minor always 2008-09-05 11:36 2008-09-08 01:36
Reporter MarkElder View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004442: Active Directory Object Picker in JvObjectPickerDialog.pas will not run on Windows Vista
Description Active Directory Object Picker in JvObjectPickerDialog.pas will not run on Windows Vista. An error "The parameter is incorrect." is raised when Execute is called.
Additional Information This is caused by this line:
725 HRes := FObjectPicker.InvokeDialog(0, DataObj);

The first paramater is a handle to the parent. This worked OK with a 0 on Windows XP but a valid window handle is required by Windows Vista.

From MSDN Help (http://msdn.microsoft.com/en-us/library/ms677102.aspx) [^]
  Syntax
    HRESULT InvokeDialog(
      HWND hwndParent,
      IDataObject** ppdoSelections);

  Parameters
  hwndParent
      Handle to the owner window of the dialog box. This parameter cannot be NULL or the result of the GetDesktopWindow function.

Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014551)
obones (administrator)
2008-09-08 01:36

This is now fixed in SVN, Application.Handle is used

- Issue History
Date Modified Username Field Change
2008-09-05 11:36 MarkElder New Issue
2008-09-08 01:36 obones Status new => resolved
2008-09-08 01:36 obones Fixed in Version => Daily / SVN
2008-09-08 01:36 obones Resolution open => fixed
2008-09-08 01:36 obones Assigned To => obones
2008-09-08 01:36 obones Note Added: 0014551


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker