Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004507 [JEDI VCL] 00 JVCL Components minor always 2008-10-07 20:53 2008-10-26 06:03
Reporter corwin View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004507: TJvAni can't load *.ANI files under Delphi 2009.
Description If you try to load ANI file into TJvAni with LoadFromFile method in application compiled under Delphi 2009 - you will get "Stream read error".
The problem is in Unicode.
Additional Information Here is solution.
In JvTypes.pas
TvFourCC = array [0..3] of Char; - Change to AnsiChar
In JvAni.pas
procedure SetFOURCC(var FourCC: TJvFourCC; ID: String); - Change to AnsiString
procedure StartWriteChunk(Stream: TStream; var Tag: TJvAniTag; ID: string); - Change to AnsiString
---
I think the same is for JvAniFile.pas
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0014912)
AHUser (developer)
2008-10-26 06:03

Fixed in SVN.

- Issue History
Date Modified Username Field Change
2008-10-07 20:53 corwin New Issue
2008-10-07 23:46 obones Status new => acknowledged
2008-10-26 06:03 AHUser Status acknowledged => resolved
2008-10-26 06:03 AHUser Fixed in Version => Daily / SVN
2008-10-26 06:03 AHUser Resolution open => fixed
2008-10-26 06:03 AHUser Assigned To => AHUser
2008-10-26 06:03 AHUser Note Added: 0014912


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker