Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004538 [JEDI VCL] 00 JVCL Components block always 2008-10-16 04:04 2008-10-16 12:14
Reporter fschenckel View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004538: Exception in TjvCsvDataset
Description Component raises the following exception :

ProcessCsvHeaderRow: Field 'Filedname with lot of garbage' found in file, but not in field definitions

It happens in ProcessCsvHeaderRow when opening the dataset.

CSV file exists, and worked well with a previous version (3.33 or 3.34 I think).
CSV file is OK and loaded correctly with an application compiled with a previous version.
Additional Information The error is in file JvCsvData, function TJvCsvStream.ReadLine: AnsiString;

I've done the following to correct the problem (seems to be introduced by unicode conversion...) :

begins at line 1214

Original code :

until not ok;
SetLength(Buf, n);

Modified code

until not ok;
inc(n);
Buf[n] := #0;
SetLength(Buf, n);

Tags No tags attached.
Attached Files ? file icon JvCsvData.pas [^] (195,580 bytes) 2008-10-16 04:04

- Relationships

-  Notes
(0014872)
obones (administrator)
2008-10-16 12:14

Thanks, this is now fixed in SVN

- Issue History
Date Modified Username Field Change
2008-10-16 04:04 fschenckel New Issue
2008-10-16 04:04 fschenckel File Added: JvCsvData.pas
2008-10-16 12:14 obones Status new => resolved
2008-10-16 12:14 obones Fixed in Version => Daily / SVN
2008-10-16 12:14 obones Resolution open => fixed
2008-10-16 12:14 obones Assigned To => obones
2008-10-16 12:14 obones Note Added: 0014872


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker