Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004558 [JEDI VCL] 02 Installation major always 2008-10-31 02:45 2008-10-31 15:36
Reporter akalwa View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004558: JVCL Installer Package Selection ChecklistBox has painting problems
Description The JVCL Installer has some serious painting problems in the package selection list (CheckListBox). The checkboxes don't paint correctly when scrolling the list:
- no checkmark but item *is* checked
- black background
See attached screenshot
Additional Information Windows XP SP3
Themes enabled
Tags No tags attached.
Attached Files png file icon JVCLInstallerPaintingProblem.png [^] (53,023 bytes) 2008-10-31 02:45

- Relationships

-  Notes
(0014935)
AHUser (developer)
2008-10-31 12:01

I only see this painting issue in with a Delphi 2009 compiled installer. The Delphi 2007 installer (and earlier Delphi versions) do not have this issue. Doesn't that mean that it is a Delphi 2009 bug from which the JVCL Installer suffers?
(0014937)
AHUser (developer)
2008-10-31 15:36

The TCheckListBox does not work with DoubleBuffered=True. And because of the new Delphi 2009 property "ParentDoubleBuffered default True" the DoubleBuffered property of the TCheckListBox becomes True if the installer is compiled with Delphi 2009.

I've added code that turns ParentDoubleBuffered off for the CheckListBox.

- Issue History
Date Modified Username Field Change
2008-10-31 02:45 akalwa New Issue
2008-10-31 02:45 akalwa File Added: JVCLInstallerPaintingProblem.png
2008-10-31 12:01 AHUser Note Added: 0014935
2008-10-31 15:36 AHUser Status new => resolved
2008-10-31 15:36 AHUser Fixed in Version => Daily / SVN
2008-10-31 15:36 AHUser Resolution open => fixed
2008-10-31 15:36 AHUser Assigned To => AHUser
2008-10-31 15:36 AHUser Note Added: 0014937


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker