Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004584 [JEDI VCL] 00 JVCL Components major always 2008-11-14 21:45 2008-12-22 05:16
Reporter Brian View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004584: JvLabel hot tracking not working
Description JvLabel's hot tracking options have no effect at all while hovering the mouse over them, the font doesn't change.
Additional Information Tested with Delphi 2009
Tags No tags attached.
Attached Files zip file icon jvlabelhottracking.zip [^] (4,327 bytes) 2008-11-20 22:43

- Relationships

-  Notes
(0015014)
obones (administrator)
2008-11-18 08:23

Please provide the zipped sources of a sample application showing this.
(0015029)
Brian (reporter)
2008-11-18 23:32

object JvLabel1: TJvLabel
  Left = 152
  Top = 152
  Width = 44
  Height = 13
  Caption = 'JvLabel1'
  Transparent = True
  HotTrack = True
  HotTrackFont.Charset = DEFAULT_CHARSET
  HotTrackFont.Color = clRed
  HotTrackFont.Height = -11
  HotTrackFont.Name = 'Tahoma'
  HotTrackFont.Style = [fsBold]
  HotTrackOptions.Color = clRed
end
(0015030)
obones (administrator)
2008-11-19 01:46

zipped sources of a complete project, please.
(0015037)
Brian (reporter)
2008-11-19 19:05

Why do you need a zipped project if you can just copy/paste this source on the form and it will re-create the component?
(0015038)
obones (administrator)
2008-11-19 23:44

Because we are very few to work on the project, we have very limited time resources and the less manipulations we have to do, the better it is. Plus there might be code/options in your project that have an impact on the issue.
(0015039)
Brian (reporter)
2008-11-20 00:24

Ok I will prepare zips for the latest few reports I've sent, although I thought just copy/pasting the object code would actually be less work/complications for you guys.
(0015041)
Brian (reporter)
2008-11-20 22:43

uploaded project
(0015146)
obones (administrator)
2008-12-22 05:16

Thanks, this is now fixed in SVN.

- Issue History
Date Modified Username Field Change
2008-11-14 21:45 Brian New Issue
2008-11-18 08:23 obones Note Added: 0015014
2008-11-18 08:23 obones Status new => feedback
2008-11-18 23:32 Brian Note Added: 0015029
2008-11-19 01:46 obones Note Added: 0015030
2008-11-19 19:05 Brian Note Added: 0015037
2008-11-19 23:44 obones Note Added: 0015038
2008-11-20 00:24 Brian Note Added: 0015039
2008-11-20 22:43 Brian File Added: jvlabelhottracking.zip
2008-11-20 22:43 Brian Note Added: 0015041
2008-12-22 05:16 obones Note Added: 0015146
2008-12-22 05:16 obones Status feedback => resolved
2008-12-22 05:16 obones Fixed in Version => Daily / SVN
2008-12-22 05:16 obones Resolution open => fixed
2008-12-22 05:16 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker