Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004585 [JEDI VCL] 00 JVCL Components major always 2008-11-14 21:48 2008-11-17 15:40
Reporter Brian View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004585: JvSpeedButton + Vista glassform: not displayed properly while inside a container
Description Try the following:

- Set form's glassframe to enabled and sheetofglass as well
- Set DoubleBuffered to True
- Place a panel on the form
- Place a JvSpeedButton on it with some text.

If the button is flat, it's filled all black
If not flat, it has a black border around
Additional Information
Tags No tags attached.
Attached Files gif file icon JvSpeedButton.gif [^] (8,263 bytes) 2008-11-16 13:00
jpg file icon Cropped Capture - 00294.jpg [^] (32,967 bytes) 2008-11-16 13:28
jpg file icon Cropped Capture - 00295.jpg [^] (31,246 bytes) 2008-11-16 13:28
rar file icon SpeedButton demo.rar [^] (5,015 bytes) 2008-11-16 13:29

- Relationships

-  Notes
(0014998)
AHUser (developer)
2008-11-15 02:42
edited on: 2008-11-15 02:43

I can't reproduce this with Delphi 2009.
Actually the TSpeedButton has this black rectangle while the TJvSpeedButton paints correctly.

(0014999)
Brian (reporter)
2008-11-15 05:09

http://i36.tinypic.com/34z15hw.jpg [^]
http://i33.tinypic.com/2nh3x9t.jpg [^]
(0015002)
AHUser (developer)
2008-11-16 13:03

I have attached a screenshot (Delphi 2007(all updates) and 2009(Update 1) look the same). And the project uses the SVN version.
Maybe I'm doing something different. A little demo project might bring light into the dark.
(0015003)
Brian (reporter)
2008-11-16 13:33

(sidenote: the text in this box is cleared after you upload a file)

Sorry I was a little wrong in my explanation. The problem actually happens while not inside a container. I have included 2 screenshots comparing different scenarios with a normal TSpeedButton and a TJvSpeedButton. The second screenshot has the window maximized. I have also included a project for you to reproduce this issue. It seems like TSpeedButton displays fine on a form but not on a panel/container, and TJvSpeedButton has the opposite behaviour. In the case of using a glyph, TSpeedButton fails in both cases.
(0015004)
AHUser (developer)
2008-11-17 15:40

The TJvSpeedButton now works on both Form and Panel. It also has a better painting of the glyph. Not perfect but there seems to be no way to get it working. I spent 4 hours getting this stupid ImageList_Draw to draw it correctly on a sheet of glass form.

- Issue History
Date Modified Username Field Change
2008-11-14 21:48 Brian New Issue
2008-11-15 02:42 AHUser Note Added: 0014998
2008-11-15 02:43 AHUser Note Edited: 0014998
2008-11-15 05:09 Brian Note Added: 0014999
2008-11-16 13:01 AHUser File Added: JvSpeedButton.gif
2008-11-16 13:03 AHUser Note Added: 0015002
2008-11-16 13:28 Brian File Added: Cropped Capture - 00294.jpg
2008-11-16 13:28 Brian File Added: Cropped Capture - 00295.jpg
2008-11-16 13:29 Brian File Added: SpeedButton demo.rar
2008-11-16 13:33 Brian Note Added: 0015003
2008-11-17 15:40 AHUser Note Added: 0015004
2008-11-17 15:40 AHUser Status new => resolved
2008-11-17 15:40 AHUser Fixed in Version => Daily / SVN
2008-11-17 15:40 AHUser Resolution open => fixed
2008-11-17 15:40 AHUser Assigned To => AHUser
2008-11-18 03:08 Brian Issue Monitored: Brian


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker