Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004628 [JEDI VCL] 00 JVCL Components trivial always 2008-12-18 16:10 2008-12-19 01:03
Reporter debose View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004628: TJvDBFindEdit.DataField cannot be removed if was set once
Description that's because of SetDataField procedure:
procedure TJvDBFindEdit.SetDataField(const Value: string);
begin
  if Value > '' then
    FDataLink.FieldName := Value;
end;

It should be, because FDataLink can process empty FieldName. (checked in Delphi 2009 and Delphi 7)
procedure TJvDBFindEdit.SetDataField(const Value: string);
begin
  FDataLink.FieldName := Value;
end;
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015111)
obones (administrator)
2008-12-19 01:03

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2008-12-18 16:10 debose New Issue
2008-12-19 01:03 obones Note Added: 0015111
2008-12-19 01:03 obones Status new => resolved
2008-12-19 01:03 obones Fixed in Version => Daily / SVN
2008-12-19 01:03 obones Resolution open => fixed
2008-12-19 01:03 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker