Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004629 [JEDI VCL] 00 JVCL Components minor have not tried 2008-12-19 02:43 2008-12-22 06:17
Reporter Stobrech View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.34
Summary 0004629: JvAppDBStorage should publish SubStorages property
Description Component JvAppDBStorage does not publish it's SubStorages property. This limits it's usability as it can't be used as a 'root' application storage. There shouldn't be any issues regarding this change since the actual SubStorage work is done by TJvCustomAppStorage superclass.
Additional Information
Tags No tags attached.
Attached Files zip file icon JVCL_issue_4629.zip [^] (2,595 bytes) 2008-12-19 12:09

- Relationships

-  Notes
(0015114)
jfudickar (developer)
2008-12-19 06:01

Hi,

if possible please create a small sample which shows the wrong behaviour.

I've never worked with DBAppstorage so this would make the support work a little bit easier :-)

Greetings and thanks
Jens
(0015116)
Stobrech (reporter)
2008-12-19 12:09

I have enclosed a small application that uses JvAppIniFileStorage as a 'root' storage, and a JvAppDBStorage as a substorage. The hierarchy is made by adding DBStorage with a RootPath='level2' into IniFileStorage.SubStorages.

The problem is you can't make it the other way round - JvAppDBStorage as a 'root' storage, and a JvAppIniFileStorage as a substorage - simply because the property SubStorages isn't published in JvAppDBStorage class. The property itself is defined as protected property in it's JvCustomAppStorage ancestor class.

I think it is safe to do. It is published in all other JvCustomAppStorage descendants (IniFileStorage, XMLFileStorage, RegistryFileStorage and AppStorage). JvAppStorage class actually does nothing but raise exceptions in all method implementations, but still publishes SubStorages property and works fine as a root container for other storages.

Besides, I changed it here myself and it works fine :) .
(0015167)
obones (administrator)
2008-12-22 06:17

Property is now published in SVN

- Issue History
Date Modified Username Field Change
2008-12-19 02:43 Stobrech New Issue
2008-12-19 06:01 jfudickar Note Added: 0015114
2008-12-19 06:01 jfudickar Status new => feedback
2008-12-19 12:09 Stobrech File Added: JVCL_issue_4629.zip
2008-12-19 12:09 Stobrech Note Added: 0015116
2008-12-22 06:17 obones Note Added: 0015167
2008-12-22 06:17 obones Status feedback => resolved
2008-12-22 06:17 obones Fixed in Version => Daily / SVN
2008-12-22 06:17 obones Resolution open => fixed
2008-12-22 06:17 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker