Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004640 [JEDI VCL] 00 JVCL Components crash always 2008-12-24 14:12 2009-10-03 20:07
Reporter debose View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004640: TJvExitWindowsDialog.Execute crashes program/or Delphi 2009 under VIsta
Description executing Execute method of TJvExitWindowsDialog crashes program. If TJvExitWindowsDialog.Execute was run from Delphi 2009 via Preview dialog menu, then IDE is crashed.

IDE: Delphi® 2009, Update Pack 1 and Update Pack 2 are installed.
Windows: Windows Vista Ultimate 32 bit, Service Pack 1.
Additional Information
Tags TJvExitWindowsDialog, Vista
Attached Files

- Relationships

-  Notes
(0015192)
obones (administrator)
2008-12-30 02:17

Must be tested under Vista, I'm not seeing this in D2009 under XP SP3
(0015203)
debose (reporter)
2009-01-03 07:06

I got similar error in Delphi7(Build 8.1).
If TJvExitWindowsDialog.Execute was run from Delphi 2009 via Preview dialog menu, then IDE is crashed.
(0015204)
debose (reporter)
2009-01-03 07:07

on same computer.(Windows Vista Ultimate 32 bit, Service Pack 1)
(0015209)
obones (administrator)
2009-01-05 00:51

Then it must be a Vista issue
(0015441)
obones (administrator)
2009-04-29 11:27

What is the value of SHShutDownDialog inside JvWinDialogs?
If it's nil, then it's because that particular dialog is no longer available in Shell32.dll
If not, then the parameters might have changed.
(0015823)
obones (administrator)
2009-07-09 17:12

Any news?
(0016239)
AHUser (developer)
2009-10-03 20:07

Fixed in SVN.

New property Kind controls the new Vista parameter (that caused the crash)

type
  TJvExitWindowsKind = (
    ekXPDialog = 0, // Show XP style shutdown dialog
    ekVistaLogoff = 1, // Vista Logoff without dialog
    ekVistaShutdown = 2 // Vista Shutdown without dialog
  );

- Issue History
Date Modified Username Field Change
2008-12-24 14:12 debose New Issue
2008-12-30 02:17 obones Note Added: 0015192
2008-12-30 02:17 obones Status new => acknowledged
2009-01-03 07:06 debose Note Added: 0015203
2009-01-03 07:07 debose Note Added: 0015204
2009-01-03 07:07 debose Tag Attached: TJvExitWindowsDialog
2009-01-03 07:07 debose Tag Attached: Vista
2009-01-05 00:51 obones Note Added: 0015209
2009-04-29 11:27 obones Note Added: 0015441
2009-04-29 11:27 obones Status acknowledged => feedback
2009-07-09 17:12 obones Note Added: 0015823
2009-10-03 20:07 AHUser Note Added: 0016239
2009-10-03 20:07 AHUser Status feedback => resolved
2009-10-03 20:07 AHUser Fixed in Version => Daily / SVN
2009-10-03 20:07 AHUser Resolution open => fixed
2009-10-03 20:07 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker