Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004681 [JEDI VCL] 00 JVCL Components major always 2009-01-29 14:59 2009-01-30 01:24
Reporter DavidVTaylor View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004681: HID components do not work in Delphi 2009
Description Some portions of HID.pas and jvHidControllerClass.pas are not Unicode ready and fail under Delphi 2009. The initial symptom was a series of internal file open exceptions while running under the IDE. No HID devices are detected.
Additional Information I have tracked down the problems which were caused by a few API calls, data structures and declarations which had not been updated. The attached files contain the changes needed to work under Delphi 2009 (search for "DVT D2009 patch"). Please note that these changes are backward compatible and have been tested under Delphi 2007. I have also included the original files for reference.
Tags No tags attached.
Attached Files zip file icon JvclHidPatch_v336.zip [^] (67,847 bytes) 2009-01-29 14:59

- Relationships

-  Notes
(0015271)
obones (administrator)
2009-01-30 01:24

Thanks, this is now in SVN.

- Issue History
Date Modified Username Field Change
2009-01-29 14:59 DavidVTaylor New Issue
2009-01-29 14:59 DavidVTaylor File Added: JvclHidPatch_v336.zip
2009-01-30 01:10 obones Status new => acknowledged
2009-01-30 01:24 obones Note Added: 0015271
2009-01-30 01:24 obones Status acknowledged => resolved
2009-01-30 01:24 obones Fixed in Version => Daily / SVN
2009-01-30 01:24 obones Resolution open => fixed
2009-01-30 01:24 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker