Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004686 [JEDI VCL] 00 JVCL Components minor always 2009-02-01 03:21 2009-03-21 17:18
Reporter paulwh View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004686: JVStringGrid.savetofile adding space between each letter
Description On savetofile adds space between letters Ie(Using 2 cells):
Drive C:\Documents and Settings\Paul\Desktop\Drive.ico
Becomes:
D r i C : \ D o c u m e n t s a n d S e t t i n g

Exact code worked fine in prior version loading and saving produced file with:
Drive C:\Documents and Settings\Paul\Desktop\Drive.ico
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015274)
obones (administrator)
2009-02-02 00:24

Which version of Delphi ?
(0015283)
paulwh (reporter)
2009-02-02 04:09

Versions:
Delphi 2009 Update 1 & 2
Delphi 2005 Personal

Although problem has resolved in Delphi 2005P with Version 3.36 but not in Delphi 2009
(0015284)
obones (administrator)
2009-02-02 07:47

So what you are saying is that the problem is NOT in D2005 but is in Delphi 2009?
Is that correct?
(0015288)
paulwh (reporter)
2009-02-04 01:32

Yes thats correct...sorry to be so cryptic but only double checked with Delphi 2005 PE after posting report.

Have since changed to savetocsv and loadfromcsv without any problem.

Thanks
Paul
(0015320)
AHUser (developer)
2009-03-21 17:18

Fixed in SVN.

This was a Unicode bug "Stream.Write(String, Len)". JvStringGrid.SaveToFile now has an optional TEncoding parameter in Delphi 2009.

- Issue History
Date Modified Username Field Change
2009-02-01 03:21 paulwh New Issue
2009-02-02 00:24 obones Note Added: 0015274
2009-02-02 00:24 obones Status new => feedback
2009-02-02 04:09 paulwh Note Added: 0015283
2009-02-02 07:47 obones Note Added: 0015284
2009-02-04 01:32 paulwh Note Added: 0015288
2009-03-21 17:18 AHUser Note Added: 0015320
2009-03-21 17:18 AHUser Status feedback => resolved
2009-03-21 17:18 AHUser Fixed in Version => Daily / SVN
2009-03-21 17:18 AHUser Resolution open => fixed
2009-03-21 17:18 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker