Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004699 [JEDI VCL] 00 JVCL Components crash always 2009-02-06 14:54 2009-04-29 14:30
Reporter teejaydub View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004699: Fix for 0003250 causes crash in particular sequence of events
Description I updated my own project from JVCL 3.30 to 3.36, and found that this section at the start of TJvTreeView.CNNotify:

    case Msg.NMHdr.code of
      TVN_SELCHANGEDA, TVN_SELCHANGEDW:
        if not Multiselect then
          FClearBeforeSelect := True;
    end;

causes a crash in one of my regression tests. This was added for the fix to issue 0003250. Since that issue deals specifically with a problem when HideSelection is true, and I'm not using HideSelection, I added "if HideSelection then" before this section to disable it.

I haven't tracked it down further than that (and the general observation that the test case deals with deleting a selected node from the tree before clearing the tree and adding more nodes), but this fix seems protective to me in the "first do no harm" sense - the fix for 0003250 is not intended to have an effect if HideSelection is False, and this ensures that.

I apologize for not giving enough info to reproduce the issue, though it is 100% reproducible for me, but I wanted to submit the fix in case it helps someone else. And if you can add the workaround, it'll make maintenance easier for me in the future.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0003250resolvedobones TJvTreeView.HideSelection doesn't work 
related to 0004808resolvedobones Treeview 

-  Notes
(0015463)
obones (administrator)
2009-04-29 14:30

Thanks, this is now fixed in SVN

- Issue History
Date Modified Username Field Change
2009-02-06 14:54 teejaydub New Issue
2009-04-29 14:27 obones Relationship added related to 0003250
2009-04-29 14:30 obones Note Added: 0015463
2009-04-29 14:30 obones Status new => resolved
2009-04-29 14:30 obones Fixed in Version => Daily / SVN
2009-04-29 14:30 obones Resolution open => fixed
2009-04-29 14:30 obones Assigned To => obones
2009-07-08 11:30 obones Relationship added related to 0004808


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker