Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004712 [JEDI VCL] 00 JVCL Components major sometimes 2009-03-20 08:23 2009-03-21 15:52
Reporter DavidVTaylor View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004712: AV in TJvGIFAnimator
Description An apparent threading problem in TJvGIFAnimator sometimes causes in AV to occur when the form containing the animated image is closed. The problem seems to be that the background thread does not terminate in a timely manner,
Additional Information The following change appears to resolve the issue based on my tests:

procedure TJvGIFAnimator.TimerExpired(Sender: TObject);
begin
  // Added check below for csDestroying to prevent AV
  if (csPaintCopy in ControlState) or (csDestroying in ComponentState) then
    Exit;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015317)
AHUser (developer)
2009-03-21 15:52

Fixed in SVN.

Thanks.

- Issue History
Date Modified Username Field Change
2009-03-20 08:23 DavidVTaylor New Issue
2009-03-21 15:52 AHUser Note Added: 0015317
2009-03-21 15:52 AHUser Status new => resolved
2009-03-21 15:52 AHUser Fixed in Version => Daily / SVN
2009-03-21 15:52 AHUser Resolution open => fixed
2009-03-21 15:52 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker