Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004714 [JEDI VCL] 00 JVCL Components minor always 2009-03-22 13:27 2009-04-29 14:42
Reporter paulwh View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004714: JvOrganizeFavoritesDialog not working for IE8
Description JvOrganizeFavoritesDialog fails to work once Internet Explorer 8 installed.
Opens a empty window.
Was working fine prior with IE7
Tried Delphi 2005PE and 2009
Using JVCL 3.3.6
Additional Information
Tags No tags attached.
Attached Files png file icon DoOpenFavDlg.png [^] (12,090 bytes) 2009-03-24 21:57
png file icon OpenFavDialogXP.PNG [^] (9,621 bytes) 2009-03-25 00:39

- Relationships

-  Notes
(0015336)
obones (administrator)
2009-03-22 19:03

IE8 has only been out for two (2) days, and you expect us to support it?
Considering the past record of Microsoft with respect to Internet Explorer, it's not even worth considering the new version until the first service pack is even out.
(0015337)
paulwh (reporter)
2009-03-22 22:33

Yes I would expect you support it else remove it from the package.
I am not asking for this immediately, I was just raising it as an issue as I am sure there will be a large number of computer users who install IE8 (or it is installed through auto updatess!) and you have a component that invokes the organize favorites dialog (only for internet explorer) that will no longer work for these users?
(0015346)
AHUser (developer)
2009-03-24 21:58

Works for me. I have attached a screenshot.
(0015348)
paulwh (reporter)
2009-03-25 00:41

Is this in Vista? I have attached a screenshot of what I get in XP. Have tried this on 2 different XP computers with IE8

Thanks Paul
(0015356)
AHUser (developer)
2009-03-26 19:32

I can't reproduce this with XP either. But for Delphi 2009 you need to update to the newest revision because there was a unicode related bug in that components (PWideChar instead of PAnsiChar)
(0015471)
obones (administrator)
2009-04-29 14:42

Assuming this is fixed in SVN

- Issue History
Date Modified Username Field Change
2009-03-22 13:27 paulwh New Issue
2009-03-22 19:03 obones Note Added: 0015336
2009-03-22 19:03 obones Status new => feedback
2009-03-22 22:33 paulwh Note Added: 0015337
2009-03-24 21:57 AHUser File Added: DoOpenFavDlg.png
2009-03-24 21:58 AHUser Note Added: 0015346
2009-03-25 00:39 paulwh File Added: OpenFavDialogXP.PNG
2009-03-25 00:41 paulwh Note Added: 0015348
2009-03-26 19:32 AHUser Note Added: 0015356
2009-04-29 14:42 obones Note Added: 0015471
2009-04-29 14:42 obones Status feedback => resolved
2009-04-29 14:42 obones Fixed in Version => Daily / SVN
2009-04-29 14:42 obones Resolution open => fixed
2009-04-29 14:42 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker