Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004724 [JEDI VCL] 00 JVCL Components minor always 2009-03-30 18:17 2009-04-29 23:33
Reporter HAM View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004724: C++ header: tkUnknown not unique
Description When I install JCL/JVCL for C++Builder 2009, JvConsts.hpp is generated.
Compilation of my JEDI based application in C++Builder leads to error:
[BCC32 Fehler] Jvconsts.hpp(121): E2015 Mehrdeutigkeit zwischen 'tkUnknown' und ...
\Include\Vcl\JvMemoryDataset.hpp
    JvMemoryDataset.hpp(22): #include c:\program files\codegear\rad studio\6.0\Include\Vcl\Jvdbutils.hpp
    Jvdbutils.hpp(23): #include c:\program files\codegear\rad studio\6.0\Include\Vcl\Jvappstorage.hpp
    Jvappstorage.hpp(25): #include c:\program files\codegear\rad studio\6.0\Include\Vcl\Jvcomponentbase.hpp
    Jvcomponentbase.hpp(18): #include c:\program files\codegear\rad studio\6.0\Include\Vcl\Jvconsts.hpp
    Jvconsts.hpp(28): namespace Jvconsts

Putting in line 121
"extern PACKAGE Set<Typinfo::TTypeKind, tkUnknown, tkUString> tkStrings;" a "Typinfo::" in front of "tkUnknown" solves the problem...
... till next installation.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015472)
obones (administrator)
2009-04-29 14:48

Please try with the latest content, I'm not seeing this at all.
If you still do, please provide the zipped sources of a sample application showing this issue.
(0015497)
HAM (reporter)
2009-04-29 18:04

OK, that seems to be solved.
No tkUnknown any more - no collisions any more.

- Issue History
Date Modified Username Field Change
2009-03-30 18:17 HAM New Issue
2009-04-29 14:48 obones Note Added: 0015472
2009-04-29 14:48 obones Status new => feedback
2009-04-29 18:04 HAM Note Added: 0015497
2009-04-29 23:33 AHUser Status feedback => resolved
2009-04-29 23:33 AHUser Fixed in Version => Daily / SVN
2009-04-29 23:33 AHUser Resolution open => fixed
2009-04-29 23:33 AHUser Assigned To => AHUser
2011-03-14 12:49 asci-g Issue Monitored: asci-g


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker