Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004725 [JEDI VCL] 00 JVCL Components major always 2009-03-30 18:25 2009-07-03 16:11
Reporter jesawyers View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004725: TJvTabDefaultPainter Incorrectly Rotating Text
Description Running BDS2006 with JVCL version 3.36

Using TJvPageControl with a TJvTabDefaultPainter

TJvPageControl.Style := tsTab;
TJvPageControl.TabPosition := tpRight;

Figured out how to get the colors to change based on the color selections
by setting TJvPageControl.OwnerDraw := true. It would be nice to have this defaulted to TRUE.

Problem I'm having is that when the TJvTabDefaultPainter paints a tab, it rotates the font text 90 degrees to dispaly the text like the TabPosition was set to tpTop. The color changing works just fine it's just the compoenent is incorrectly rotating the text.

Because the TabPosition is tpRight the text is displayed top to bottom on the tab and this works during design time and is the behvior I want.

During runtime, all the tabs captions are rotated 90 degrees CCW.
Additional Information
Tags No tags attached.
Attached Files zip file icon Problem Example.zip [^] (328,131 bytes) 2009-05-10 18:15

- Relationships

-  Notes
(0015473)
obones (administrator)
2009-04-29 14:48

Please provide the zipped sources of a sample application showing this.
(0015520)
jesawyers (reporter)
2009-05-10 18:17

Uploaded a sample application showing the problem. Note during designtime the tabs on the right are normal with the tab text displayed top to bottom.

When you run the application, the tab painter will rotate the text to display left to right instead of top to bottom.
(0015753)
obones (administrator)
2009-07-03 16:11

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2009-03-30 18:25 jesawyers New Issue
2009-04-29 14:48 obones Note Added: 0015473
2009-04-29 14:48 obones Status new => feedback
2009-05-10 18:15 jesawyers File Added: Problem Example.zip
2009-05-10 18:17 jesawyers Note Added: 0015520
2009-07-03 16:11 obones Note Added: 0015753
2009-07-03 16:11 obones Status feedback => resolved
2009-07-03 16:11 obones Fixed in Version => Daily / SVN
2009-07-03 16:11 obones Resolution open => fixed
2009-07-03 16:11 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker