Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004738 [JEDI VCL] 00 JVCL Components feature always 2009-04-10 00:17 2009-04-11 20:08
Reporter munggaran View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004738: Unable to Insert Object on JvRichEdit/JvDBRichEdit with Delphi 2009
Description I've tried to upgrade my Delphi 2007 project to Delphi 2009, but it seems to have problem InsertObjectDialog.

on Delphi 2007 it will bring insert object dialog, but on Delphi 2009 nothing is happen.
Additional Information
Tags No tags attached.
Attached Files zip file icon JvRichEdit.zip [^] (71,741 bytes) 2009-04-10 08:57

- Relationships

-  Notes
(0015395)
obones (administrator)
2009-04-10 08:50

Please provide the zipped sources of a sample application showing this.
(0015396)
munggaran (reporter)
2009-04-10 08:57

this is source of jvcl JvRichEdit example(JVCL336CompleteJCL1104-Build3248), uploaded anyway...
(0015397)
obones (administrator)
2009-04-10 10:19

Please try with the latest SVN version, changes have been made to fix some D2009 issues
(0015398)
munggaran (reporter)
2009-04-10 19:09

dude, I'm using latest version.., if there any other latest version after JVCL336-Build3248, please let me know so I can download and test it :)
(0015399)
obones (administrator)
2009-04-10 21:15

No you're not. If I'm talking about the SVN version it's because it's more advanced than the one you have.
Have a look here:

http://jvcl.sf.net/daily/ [^]

and read the instructions
(0015403)
munggaran (reporter)
2009-04-11 00:59

I've uninstalled current jcl, jvcl, then download+install SVN version you gave me, but still nothing happen when I execute following code :

myjvRichEdit.InsertObjectDialog;


it's only occur on delphi 2009.

if you want to reproduce, just put a jvRichEdit and a button the form executing myjvRichEdit.InsertObjectDialog.
(0015405)
AHUser (developer)
2009-04-11 20:08

There is something weird going on in the OleUIInsertObjectW function. It fails with OLEUI_IOERR_LPCLSIDEXCLUDEINVALID but we do not use this field (it is set to nil)

For now I have changed the code to use the ANSI function OleUIInsertObjectA instead which still works.

- Issue History
Date Modified Username Field Change
2009-04-10 00:17 munggaran New Issue
2009-04-10 08:50 obones Note Added: 0015395
2009-04-10 08:50 obones Status new => feedback
2009-04-10 08:57 munggaran Note Added: 0015396
2009-04-10 08:57 munggaran File Added: JvRichEdit.zip
2009-04-10 10:19 obones Note Added: 0015397
2009-04-10 19:09 munggaran Note Added: 0015398
2009-04-10 21:15 obones Note Added: 0015399
2009-04-11 00:59 munggaran Note Added: 0015403
2009-04-11 20:08 AHUser Note Added: 0015405
2009-04-11 20:08 AHUser Status feedback => resolved
2009-04-11 20:08 AHUser Fixed in Version => Daily / SVN
2009-04-11 20:08 AHUser Resolution open => fixed
2009-04-11 20:08 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker