Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004772 [JEDI VCL] 00 JVCL Components minor always 2009-05-07 14:29 2009-08-04 14:31
Reporter KirillZ View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004772: errors with dock components in Delphi 2009
Description This bug was found in version 3.36, it appears in Daily update January 2009.
Here are actions which illustrate our problem:

1. We use your \jvcl\examples\JvDocking\AdvanceDemo\Delphi_Source demo with slight changes: the components are created in run-time (a limitation caused by our developer environment). We run demo in Delphi 2009.
2. We run the demo
3. Set Server Style > VSNet style
4. Create 4 forms (VSNet style)
5. Then we insert (dock) dockforms to left, right, top and bottom dockzones.
6. Dock Information > Save To Ini File
7. Undock one (any) of dockforms.
8. Dock Information > Load From Ini File
9. All forms undock from their dockzones, while it looks like dockforms’ positions should be loaded from ini file.
10. Repeat 5th action.
11. Repeat 6th action.
12. Repeat 8th action. We get Access Violation and all dockforms disappear (we cannot see them). Next repeating of 8th action invokes Access Violation as well.
13. Create 4 forms (VSNet style)
14. Dock one form to the top dockzone – it docks, but it is impossible to undock.
15. Dock one form to the left dockzone – it docks, but the client’s section of the dockform disappears (we can see close and fix buttons of the dockform only).
16. Dock one form to the bottom dockzone – it docks, but the client’s section of the dockform disappears (we cannot see even close and fix buttons of the dockform).
17. Dock one form to the right dockzone – see 15th action.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0015752)
obones (administrator)
2009-07-03 13:38

Please try with the latest release, I cannot repeat the problem.
Whatever the results, please let us know
(0015907)
obones (administrator)
2009-08-04 09:38

Hello, any news?
(0015912)
KirillZ (reporter)
2009-08-04 12:51

We've tested the latest sources and no problem was found.
Thank you for your consideration.
(0015913)
obones (administrator)
2009-08-04 14:31

No worries, thanks for letting us know

- Issue History
Date Modified Username Field Change
2009-05-07 14:29 KirillZ New Issue
2009-07-03 13:38 obones Note Added: 0015752
2009-07-03 13:38 obones Status new => feedback
2009-08-04 09:38 obones Note Added: 0015907
2009-08-04 12:51 KirillZ Note Added: 0015912
2009-08-04 14:31 obones Note Added: 0015913
2009-08-04 14:31 obones Status feedback => resolved
2009-08-04 14:31 obones Fixed in Version => 3.37
2009-08-04 14:31 obones Resolution open => fixed
2009-08-04 14:31 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker