Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004778 [JEDI VCL] 00 JVCL Components crash always 2009-05-14 18:30 2009-06-18 22:31
Reporter JohnML View Status public  
Assigned To wpostma416
Priority normal Resolution fixed  
Status resolved   Product Version 3.36
Summary 0004778: JvCSVDataset.Sort --> leads to an error
Description First of all, thanks for your great work !!

And now the problem with JvCSVDataset.Sort

Compile the attached sample app ...

If you use TitleButtonClick several times to sort the Data you get an error.

Sometimes the Error Message says "Field not found" and i can see that the fixed row of the Grid contains any more the Fieldname, but "project1" for example.

I have an app compiled with an older version of JVCL and JCL and this app doesn't have this problems.

I have Delphi 5 Pro, Windows XP SP3 and the latest JVCL 3.36 and JCL

Regards

John
Additional Information
Tags JvCSVDataset, sorting
Attached Files zip file icon JvCSVDataset.Sort-Error.zip [^] (4,385 bytes) 2009-05-14 18:30
jpg file icon ErrorMessage1.JPG [^] (82,336 bytes) 2009-06-11 13:15
7z file icon Poject1.7z [^] (689,820 bytes) 2009-06-11 13:28
? file icon JvCsvData.pas [^] (197,850 bytes) 2009-06-18 22:02

- Relationships

-  Notes
(0015522)
JohnML (reporter)
2009-05-15 12:26

p.s.:

you have to sort the same column ascending and then descending repeatedly to reproduce the error !
(0015640)
wpostma416 (developer)
2009-06-09 19:58

I will try this one out. CsvDataSet is my baby. :-)
(0015641)
wpostma416 (developer)
2009-06-09 20:03

Unable to reproduce on Delphi 7, with latest SVN-head version of JCL/JVCL.

Can you please recompile this on your own version, using the JCLDebug feature to catch the exception and dump me out a stack trace so I can see where is the problem happening, and what the call tree looks like on your side please?
(0015652)
JohnML (reporter)
2009-06-10 09:05

Hi,

I will try to recompile my JVCL 3.36, using the JCLDebug feature.
I have never done that before, but i hope i can manage that.

I'll will try to reproduce this error on a Delphi 7 too!
(0015658)
JohnML (reporter)
2009-06-11 13:50

Sorry, but i don't know who to "dump out a stack trace" with my Delphi 5 Pro.

So i recompiled the known sample project1 ( see JvCSVDataset.Sort-Error.zip ) with JCL Debug expert turned on :
"create .jdbg files .. into binary"
and i get an error message as you can see with my attached screenshot "ErrorMessage1.JPG".

I also attached the project1.exe *.jdbg *.map in "Poject1.7z".
The project1.exe in that 7-zip archive is compressed using upx.exe

Hope, you can get some useful information out of that.

I'll now try to test project1 with Delphi 7 and i try to use the old JvCSVDataset.Sort function out of an older version of JVCL and JCL.

I think the issue has to do with:

JvCSVData.pas, Line 4113:
SortColumnCount := Jv(!!!)Ansi(!!!)StrSplit

I will put another notice here if i get some useful information out of that.
(0015659)
AHUser (developer)
2009-06-11 21:19

The JvCSVData.pas unit was ansified in the 3.36 release. But on May 19th I have undone the ansification and that's why wpostma416 can't reproduce the bug with the SVN-head version. The unit is now back to "string" which means JvAnsiStrSplit isn't used anymore.
(0015660)
wpostma416 (developer)
2009-06-11 21:26

Excellent!
(0015661)
wpostma416 (developer)
2009-06-11 21:34

Reminder sent to: JohnML

Hi John,

For future reference by stack trace, I mean, you compile the JCL debug feature into your application, or you can use the delphi debugger Call Stack window: While in the debugger hit Ctrl+Alt+S then Ctrl+A (select all) then Ctrl+C (copy) then go to Notepad or right to the mantis issue here, and paste the call sequence, like this:

TForm1.Button1Click($1DF36D0)
TControl.Click
TButton.Click
TButton.CNCommand((48401, 2370, 0, 461122, 0))
TControl.WndProc((48401, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TWinControl.WndProc((48401, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TButtonControl.WndProc((48401, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TControl.Perform(48401,2370,461122)
DoControlMsg(461122,(no value))
TWinControl.WMCommand((273, 2370, 0, 461122, 0))
TCustomForm.WMCommand((273, 2370, 0, 461122, 0))
TControl.WndProc((273, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TWinControl.WndProc((273, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TCustomForm.WndProc((273, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
TWinControl.MainWndProc((273, 2370, 461122, 0, 2370, 0, 2370, 7, 0, 0))
StdWndProc(657712,273,2370,461122)
TWinControl.DefaultHandler((no value))
TControl.WMLButtonUp((514, 0, 55, 22, (55, 22), 0))
TControl.WndProc((514, 0, 1441847, 0, 0, 0, 55, 22, 0, 0))
TWinControl.WndProc((514, 0, 1441847, 0, 0, 0, 55, 22, 0, 0))
TButtonControl.WndProc((514, 0, 1441847, 0, 0, 0, 55, 22, 0, 0))
TWinControl.MainWndProc((514, 0, 1441847, 0, 0, 0, 55, 22, 0, 0))
StdWndProc(461122,514,0,1441847)
TApplication.HandleMessage
TApplication.Run
Project1

See how it starts with Project name at the bottom, top level function is usually TApplication.Run, and then above that, you can see what function is calling what,and with what parameters.

W
(0015663)
JohnML (reporter)
2009-06-12 00:14

I tried to compile the SVN-zipped version from today, but i get an error, compiling jcl:
JclContainerIntf.pas(285) Fehler: Undefinierter Bezeichner: 'TJclAnsiStrings'
JclContainerIntf.pas(306) Fehler: Undefinierter Bezeichner: 'TJclWideStrings'
JclContainerIntf.pas(311) Fehler: Undefinierter Bezeichner: 'WideLineBreak'

So i wait some days and try again, because AHuser fixed the problem ?!!


Perhaps the stack trace is still usefull for somebody:
CreateAVObject
GetExceptionObject($33194)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($33B80)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3456C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($34F58)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($35944)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($36330)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($36D1C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($37708)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($380F4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($38AE0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($394CC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($39EB8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3A8A4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3B290)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3BC7C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3C668)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3D054)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3DA40)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3E42C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3EE18)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($3F804)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($401F0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($40BDC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($415C8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($41FB4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($429A0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4338C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($43D78)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($44764)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($45150)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($45B3C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($46528)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($46F14)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($47900)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($482EC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($48CD8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($496C4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4A0B0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4AA9C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4B488)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4BE74)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4C860)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4D24C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4DC38)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4E624)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4F010)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($4F9FC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($503E8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($50DD4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($517C0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($521AC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($52B98)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($53584)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($53F70)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5495C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($55348)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($55D34)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($56720)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5710C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($57AF8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($584E4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($58ED0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($598BC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5A2A8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5AC94)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5B680)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5C06C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5CA58)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5D444)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5DE30)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5E81C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5F208)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($5FBF4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($605E0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($60FCC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($619B8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($623A4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($62D90)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6377C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($64168)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($64B54)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($65540)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($65F2C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($66918)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($67304)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($67CF0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($686DC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($690C8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($69AB4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6A4A0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6AE8C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6B878)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6C264)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6CC50)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6D63C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6E028)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6EA14)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6F400)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($6FDEC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($707D8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($711C4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($71BB0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7259C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($72F88)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($73974)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($74360)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($74D4C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($75738)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($76124)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($76B10)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($774FC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($77EE8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($788D4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($792C0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($79CAC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7A698)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7B084)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7BA70)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7C45C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7CE48)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7D834)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7E220)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7EC0C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7F5F8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($7FFE4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($809D0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($813BC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($81DA8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($82794)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($83180)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($83B6C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($84558)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($84F44)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($85930)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8631C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($86D08)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($876F4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($880E0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($88ACC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($894B8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($89EA4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8A890)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8B27C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8BC68)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8C654)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8D040)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8DA2C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8E418)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8EE04)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($8F7F0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($901DC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($90BC8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($915B4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($91FA0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9298C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($93378)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($93D64)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($94750)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9513C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($95B28)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($96514)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($96F00)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($978EC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($982D8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($98CC4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($996B0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9A09C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9AA88)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9B474)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9BE60)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9C84C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9D238)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9DC24)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9E610)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9EFFC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($9F9E8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A03D4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A0DC0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A17AC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A2198)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A2B84)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A3570)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A3F5C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A4948)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A5334)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A5D20)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A670C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A70F8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A7AE4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A84D0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A8EBC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($A98A8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AA294)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AAC80)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AB66C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AC058)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($ACA44)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AD430)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($ADE1C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AE808)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AF1F4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($AFBE0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B05CC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B0FB8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B19A4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B2390)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B2D7C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B3768)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B4154)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B4B40)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B552C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B5F18)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B6904)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B72F0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B7CDC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B86C8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B90B4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($B9AA0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BA48C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BAE78)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BB864)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BC250)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BCC3C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BD628)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BE014)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BEA00)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BF3EC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($BFDD8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C07C4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C11B0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C1B9C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C2588)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C2F74)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C3960)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C434C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C4D38)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C5724)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C6110)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C6AFC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C74E8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C7ED4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C88C0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C92AC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($C9C98)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CA684)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CB070)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CBA5C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CC448)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CCE34)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CD820)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CE20C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CEBF8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CF5E4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($CFFD0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D09BC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D13A8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D1D94)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D2780)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D316C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D3B58)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D4544)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D4F30)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D591C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D6308)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D6CF4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D76E0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D80CC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D8AB8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D94A4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($D9E90)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DA87C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DB268)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DBC54)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DC640)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DD02C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DDA18)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DE404)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DEDF0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($DF7DC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E01C8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E0BB4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E15A0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E1F8C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E2978)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E3364)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E3D50)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E473C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E5128)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E5B14)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E6500)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E6EEC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E78D8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E82C4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E8CB0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($E969C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EA088)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EAA74)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EB460)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EBE4C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EC838)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($ED224)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EDC10)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EE5FC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EEFE8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($EF9D4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F03C0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F0DAC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F1798)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F2184)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F2B70)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F355C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F3F48)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F4934)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F5320)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F5D0C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F66F8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F70E4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F7AD0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F84BC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F8EA8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($F9894)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FA280)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FAC6C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FB658)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FC044)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FCA30)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FD41C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FDE08)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FE7F4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FF1E0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($FFBCC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1005B8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($100FA4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($101990)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10237C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($102D68)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($103754)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($104140)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($104B2C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($105518)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($105F04)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1068F0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1072DC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($107CC8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1086B4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1090A0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($109A8C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10A478)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10AE64)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10B850)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10C23C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10CC28)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10D614)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10E000)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10E9EC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10F3D8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($10FDC4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1107B0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11119C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($111B88)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($112574)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($112F60)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11394C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($114338)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($114D24)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($115710)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1160FC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($116AE8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1174D4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($117EC0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1188AC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($119298)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($119C84)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11A670)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11B05C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11BA48)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11C434)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11CE20)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11D80C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11E1F8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11EBE4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11F5D0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($11FFBC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1209A8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($121394)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($121D80)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12276C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($123158)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($123B44)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($124530)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($124F1C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($125908)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1262F4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($126CE0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1276CC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($1280B8)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($128AA4)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($129490)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($129E7C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12A868)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12B254)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12BC40)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12C62C)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12D018)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12DA04)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12E3F0)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12EDDC)
@HandleAnyException
@GetMem
@NewAnsiString
CreateAVObject
GetExceptionObject($12F7C8)
@HandleAnyException
SysFreeMem($A193D4)
@FreeMem
@LStrArrayClr
JvCsvDatabaseError(???,???)
TMainForm1.JvDBGrid1TitleBtnClick($A19D50,0,$A192FC)
TJvDBGrid.DoTitleClick(0,$A192FC)
TJvDBGrid.MouseUp(mbLeft,[],332,11)
TControl.DoMouseUp((514, 0, 332, 11, (332, 11), 0),mbLeft)
TControl.WMLButtonUp((514, 0, 332, 11, (332, 11), 0))
TControl.WndProc((514, 0, 721228, 0, 0, 0, 332, 11, 0, 0))
TWinControl.WndProc((514, 0, 721228, 0, 0, 0, 332, 11, 0, 0))
(0015664)
JohnML (reporter)
2009-06-12 00:28

AHuser told us:
"The JvCSVData.pas unit was ansified in the 3.36 release. But on May 19th I have undone the ansification and that's why wpostma416 can't reproduce the bug with the SVN-head version."

But!
I have the 3.36 release and compiled my sample project1 with Delphi 7 and i get NO(!!) errors.
Seems to be a problem of D5 and not jcl or jvcl !??
(0015669)
AHUser (developer)
2009-06-13 13:22

It must not be my changes, also Marcel Bestebroer wrote some unit test for JclStrings/JclAnsiStrings and fixed some bugs in it.
(0015702)
JohnML (reporter)
2009-06-18 22:00

I have a workaround for the problem:

I patched JVCL 336, JvCSVData.pas:

i replaced "procedure TJvCustomCsvDataSet.Sort" from JVCL 336 with
"procedure TJvCustomCsvDataSet.Sort" out of a daily spnapshot: "JVCL3-2009-06-11.zip"

See line >4093 of the attached file JvCSVData.pas

Now i can use the Sort procedure with my Delphi 5 again and thats a good solution!

Perhaps thats useful for somebody else. If you want to use the patched JvCSVData.pas you have to uninstall/intsall JVCL in your Delphi 5.

For me the issue is solved!
(0015703)
wpostma416 (developer)
2009-06-18 22:29

User reports latest SVN as of June 11 has bug fixed already.
(0015704)
wpostma416 (developer)
2009-06-18 22:31

User reported that June 11 SVN dailyzip version has already fixed this issue.
(User was using a much older version so we're not sure when along the way it was fixed but someone rewrote the AnsiString utility functions in question at some point, and probably fixed this)

- Issue History
Date Modified Username Field Change
2009-05-14 18:30 JohnML New Issue
2009-05-14 18:30 JohnML File Added: JvCSVDataset.Sort-Error.zip
2009-05-14 18:32 JohnML Issue Monitored: JohnML
2009-05-15 12:26 JohnML Note Added: 0015522
2009-05-15 12:30 JohnML Tag Attached: JvCSVDataset
2009-05-15 12:30 JohnML Tag Attached: sorting
2009-06-09 19:58 wpostma416 Note Added: 0015640
2009-06-09 20:03 wpostma416 Note Added: 0015641
2009-06-09 20:03 wpostma416 Assigned To => wpostma416
2009-06-10 08:48 obones Status new => feedback
2009-06-10 09:05 JohnML Note Added: 0015652
2009-06-11 13:15 JohnML File Added: ErrorMessage1.JPG
2009-06-11 13:28 JohnML File Added: Poject1.7z
2009-06-11 13:50 JohnML Note Added: 0015658
2009-06-11 21:19 AHUser Note Added: 0015659
2009-06-11 21:26 wpostma416 Note Added: 0015660
2009-06-11 21:34 wpostma416 Note Added: 0015661
2009-06-12 00:14 JohnML Note Added: 0015663
2009-06-12 00:28 JohnML Note Added: 0015664
2009-06-13 13:22 AHUser Note Added: 0015669
2009-06-18 22:00 JohnML Note Added: 0015702
2009-06-18 22:02 JohnML File Added: JvCsvData.pas
2009-06-18 22:29 wpostma416 Note Added: 0015703
2009-06-18 22:31 wpostma416 Note Added: 0015704
2009-06-18 22:31 wpostma416 Status feedback => resolved
2009-06-18 22:31 wpostma416 Fixed in Version => Daily / SVN
2009-06-18 22:31 wpostma416 Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker