Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004780 [JEDI VCL] 00 JVCL Components major always 2009-05-19 16:49 2011-09-21 14:10
Reporter westphal View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004780: TJvFilenameEdit not working with localized filename on D7
Description unless set OEMConvert property from true(default) to false.

I can sse in the code that this property is set to false only when unicode is defined, but this is not a Delphi 7 thing.
Additional Information
Tags No tags attached.
Attached Files zip file icon mantis0004780.zip [^] (355,055 bytes) 2009-06-23 10:49

- Relationships

-  Notes
(0015685)
obones (administrator)
2009-06-16 11:39

Please provide the zipped sources of a sample application showing this
(0015713)
westphal (reporter)
2009-06-23 10:51

Please find the attached zip that contain an example of the bug. There is also the .exe file that was compiled with D7.

note: I did not upgrade jcl/jvcl since the first post.
(0015884)
westphal (reporter)
2009-07-23 15:23

After further tests, this bug inerits from TCustomEdit.

The only thing remaining is that, when you put a Tedit on a D7 form, the published OEMConvert property is set by default to false.

But for the components TJvFilenameEdit and TJvDirectoryEdit it's set by default to true and that raise bugs with localized filenames.
(0015885)
westphal (reporter)
2009-07-23 15:43

If fact, both related bugs/comments 3621 and 4454 lead to set this property to false by default.
(0015886)
westphal (reporter)
2009-07-23 17:30

In revision 10503, this property as been set to true by remkobonte because:

"Added default True to property OEMConvert because it is set to true in the constructor."

And this is true since revision 2004. But again on D7 (and newer) it seem to lead to a bug if we do not set this property to false.
(0015887)
westphal (reporter)
2009-07-23 18:04

In fact, OEMConvert shoud also not be set to true in the constructor.
(0017088)
westphal (reporter)
2010-01-11 13:06

Hi,
This issue looks like it's a dead Issue, but the bug is still here. Can i do something to help on this one ?
(0017116)
obones (administrator)
2010-01-13 17:05

This issue will be looked at, but it would help if you could send us some "offending" files in a zip.
(0018298)
westphal (reporter)
2011-01-14 19:53

This bug has been corrected since current revision(12955).

- Issue History
Date Modified Username Field Change
2009-05-19 16:49 westphal New Issue
2009-05-23 20:04 samanman Issue Monitored: samanman
2009-05-23 20:04 samanman Issue End Monitor: samanman
2009-06-16 11:39 obones Note Added: 0015685
2009-06-16 11:39 obones Status new => feedback
2009-06-23 10:49 westphal File Added: mantis0004780.zip
2009-06-23 10:51 westphal Note Added: 0015713
2009-07-03 17:27 obones Status feedback => acknowledged
2009-07-23 15:23 westphal Note Added: 0015884
2009-07-23 15:43 westphal Note Added: 0015885
2009-07-23 17:30 westphal Note Added: 0015886
2009-07-23 18:04 westphal Note Added: 0015887
2010-01-11 13:06 westphal Note Added: 0017088
2010-01-13 17:05 obones Target Version => 3.40 - not yet released
2010-01-13 17:05 obones Note Added: 0017116
2011-01-14 19:53 westphal Note Added: 0018298
2011-01-24 20:58 AHUser Status acknowledged => resolved
2011-01-24 20:58 AHUser Fixed in Version => Daily / SVN
2011-01-24 20:58 AHUser Resolution open => fixed
2011-01-24 20:58 AHUser Assigned To => AHUser
2011-09-21 14:10 obones Fixed in Version Daily / SVN => 3.45


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker