Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004833 [JEDI VCL] 00 JVCL Components crash always 2009-06-23 11:37 2009-07-08 12:10
Reporter ZENsan View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version Daily / GIT
Summary 0004833: TJvTimer thread appeareance must be recoded
Description TJvTimer thread appeareance must be recoded.

1) Run attached project.
2) Press on "Create TTimers" button - this will create 3000 timers with Enabled = False (all is ok), I can create as many timers as I need.
3) Press on "Create TJvTimers" button - doing the same.. leads to access violation. And this is really painfull problem, that when TJvTimer is created it always allocates thread even if it is not enabled.
Additional Information I suggest to skip thread creation if Threaded = False (because then JvTimer do not work as stable as standard TTimer and eats much resources by creating useless thread handles. Or better to create thread only when Enabled is set to true, and when it is set to False to terminate and free associated thread.
Tags No tags attached.
Attached Files 7z file icon JvTimer.7z [^] (958 bytes) 2009-06-23 11:37

- Relationships

-  Notes
(0015777)
obones (administrator)
2009-07-08 12:10

This is now fixed in SVN

- Issue History
Date Modified Username Field Change
2009-06-23 11:37 ZENsan New Issue
2009-06-23 11:37 ZENsan File Added: JvTimer.7z
2009-07-03 17:28 obones Status new => acknowledged
2009-07-08 12:10 obones Note Added: 0015777
2009-07-08 12:10 obones Status acknowledged => resolved
2009-07-08 12:10 obones Fixed in Version => Daily / SVN
2009-07-08 12:10 obones Resolution open => fixed
2009-07-08 12:10 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker