Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004874 [JEDI VCL] 00 JVCL Components block always 2009-07-23 19:11 2009-08-23 12:43
Reporter Onjahyr View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.37
Summary 0004874: I found a bug in TJvXPButton. I noticed a interesting detail.
Description 1. Create a new project;
2. Place a TJvXPButton (Jv XP Controls pallete) in the form;
3. If needed, set AutoGray property to False;
4. Type the following code for OnClick event:
   [ BEGIN OF CODE ]
     if( ( Sender as TJvXPButton ).isLocked = False ) then
       ( Sender as TJvXPButton).isLocked := True;
   [ END ]
5. Run the application;
6. Minimize the application form or switch to other window;
7. Restore or switch to the application form;
8. BUG! TJvXPButton has not "Down" appearence.

The bug can be related to component repainting, causing this "lack" in the appearance.
Additional Information
Tags No tags attached.
Attached Files zip file icon Bug in TjvXPButton.zip [^] (5,454 bytes) 2009-08-18 15:37

- Relationships

-  Notes
(0015908)
obones (administrator)
2009-08-04 09:39

Please provide the zipped sources of a sample application showing this.
(0016002)
Onjahyr (reporter)
2009-08-18 15:38

Add zipped source
(0016007)
AHUser (developer)
2009-08-23 11:51

IsLocked := True disables the repainting of the button. I don't know why this property has write access. It is controlled by BeginUpdate/EndUpdate. I will remove the write access.
(0016008)
AHUser (developer)
2009-08-23 12:43

This is by design. The purpose of IsLocked is to disable repainting and not to keep the button in down state. I have now removed the write access to IsLocked with the hint that BeginUpdate/EndUpdate should be used instead.
And I have added a new property "Down: Boolean" that keeps the button pressed.

- Issue History
Date Modified Username Field Change
2009-07-23 19:11 Onjahyr New Issue
2009-07-23 19:13 Onjahyr Issue Monitored: Onjahyr
2009-07-23 19:13 Onjahyr Issue End Monitor: Onjahyr
2009-08-04 09:39 obones Note Added: 0015908
2009-08-04 09:39 obones Status new => feedback
2009-08-18 15:37 Onjahyr File Added: Bug in TjvXPButton.zip
2009-08-18 15:38 Onjahyr Note Added: 0016002
2009-08-23 11:51 AHUser Note Added: 0016007
2009-08-23 12:43 AHUser Note Added: 0016008
2009-08-23 12:43 AHUser Status feedback => resolved
2009-08-23 12:43 AHUser Fixed in Version => Daily / SVN
2009-08-23 12:43 AHUser Resolution open => fixed
2009-08-23 12:43 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker